summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-09-21 20:36:56 -0400
committerTony Lambiris2018-09-21 20:36:56 -0400
commitef7faaf6a9f5bed7610ece09f9de7c3bb4633872 (patch)
treeb78d98c19ee232e1d06983a62acd33432536e0a5
downloadaur-ef7faaf6a9f5bed7610ece09f9de7c3bb4633872.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2de760c5f23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-miniview-git
+ pkgdesc = GNOME Shell plugin that shows a preview window overlay
+ pkgver = 16.3207b65
+ pkgrel = 1
+ url = https://github.com/iamlemec/miniview
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ source = gnome-shell-extension-miniview-git::git+https://github.com/iamlemec/miniview.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-miniview-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5217ac8db991
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=gnome-shell-extension-miniview-git
+pkgver=16.3207b65
+pkgrel=1
+pkgdesc="GNOME Shell plugin that shows a preview window overlay"
+arch=('any')
+url="https://github.com/iamlemec/miniview"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/iamlemec/miniview.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd ${pkgname}
+
+ _extid="miniview@thesecretaryofwar.com"
+ _extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"
+
+ install -dm755 "${_extpath}"
+ cp -a * "${_extpath}"
+}