summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2021-04-14 00:03:35 -0400
committerTony Lambiris2021-04-14 00:03:35 -0400
commitbffadb3fbaf4095d4784f0a3c7c001cb249f6643 (patch)
treecad395e16b8a889d659474cd5b6329f9b324b42f
parent1c71879f18aaa0e464d0b62953edd5f68369f6ed (diff)
downloadaur-bffadb3fbaf4095d4784f0a3c7c001cb249f6643.tar.gz
Version bump
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD15
3 files changed, 12 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99f3c0885b2c..23352884232c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = gnome-shell-extension-mmod-panel-git
pkgdesc = Create a customizable panel for Gnome 3
- pkgver = r40.40a58cd
- pkgrel = 2
- url = https://github.com/RyanGipson/mmod-panel
+ pkgver = v0.1.4.r28.g40a58cd
+ pkgrel = 1
+ url = https://github.com/RyanGipson/mmod-panel.git
arch = any
license = GPL3
makedepends = git
depends = gnome-shell
- source = git+https://github.com/RyanGipson/mmod-panel.git
+ source = gnome-shell-extension-mmod-panel-git::git+https://github.com/RyanGipson/mmod-panel.git
sha256sums = SKIP
pkgname = gnome-shell-extension-mmod-panel-git
diff --git a/.gitignore b/.gitignore
index be9152d07b05..3cbe9be48a4d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,5 @@
src
pkg
mmod-panel
-*pkg.tar.xz
+*.pkg.tar.*
tags
diff --git a/PKGBUILD b/PKGBUILD
index ca37a643b90b..fc0dc1612f26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Tony Lambiris <tony@libpcap.net>
pkgname=gnome-shell-extension-mmod-panel-git
-_gitname=mmod-panel
-pkgver=r40.40a58cd
-pkgrel=2
+pkgver=v0.1.4.r28.g40a58cd
+pkgrel=1
pkgdesc="Create a customizable panel for Gnome 3"
arch=('any')
-url="https://github.com/RyanGipson/mmod-panel"
+url="https://github.com/RyanGipson/mmod-panel.git"
license=('GPL3')
depends=('gnome-shell')
makedepends=('git')
-source=('git+https://github.com/RyanGipson/mmod-panel.git')
+source=("${pkgname}::git+${url}")
sha256sums=('SKIP')
pkgver() {
- cd $_gitname
+ cd "${srcdir}/${pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd $_gitname
+ cd "${srcdir}/${pkgname}"
_extid="mmod-panel@mmogp.com"
_extpath="${pkgdir}/usr/share/gnome-shell/extensions/${_extid}"