summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-01-20 15:50:32 -0700
committerMark Wagie2024-01-20 15:50:32 -0700
commit555dd31d28bbe1ecefc21131918b440585acf27e (patch)
tree1906b7f32901ac40c6f0f0efc71bc4b0c7fa3d9c
parente1a86913e7a495179dceb1551b8ca8081318554b (diff)
downloadaur-gnome-shell-extension-multi-monitors-add-on-git.tar.gz
use SPDX license identifier
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0eda181b8758..629130a8d6da 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,7 +5,7 @@ pkgbase = gnome-shell-extension-multi-monitors-add-on-git
epoch = 1
url = https://github.com/realh/multi-monitors-add-on
arch = any
- license = GPL2
+ license = GPL-2.0-or-later
makedepends = git
depends = gnome-shell<=1:44.6
provides = gnome-shell-extension-multi-monitors-add-on
diff --git a/PKGBUILD b/PKGBUILD
index 0fa9a7695bc4..e0c717f1f923 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Tom Wagner <tom dot a dot wagner at protonmail dot com>
# Contributor: smcdougall <simon at sjmcdougall dot com>
pkgname=gnome-shell-extension-multi-monitors-add-on-git
-_pkgname=multi-monitors-add-on
+_uuid=multi-monitors-add-on@spin83
pkgver=19.r49.gd8ea040
pkgrel=1
epoch=1
pkgdesc="Adds panels and thumbnails for additional monitors."
arch=('any')
url="https://github.com/realh/multi-monitors-add-on"
-license=('GPL2')
+license=('GPL-2.0-or-later')
depends=('gnome-shell<=1:44.6')
makedepends=('git')
provides=("${pkgname%-git}")
@@ -18,22 +18,25 @@ source=('git+https://github.com/realh/multi-monitors-add-on.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd multi-monitors-add-on
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/$_pkgname"
-
- _uuid="$_pkgname@spin83"
+ cd multi-monitors-add-on
install -d "$pkgdir/usr/share/gnome-shell/extensions/"
cp -a "$_uuid/" "$pkgdir/usr/share/gnome-shell/extensions/"
- install -Dm644 "$_uuid/schemas/org.gnome.shell.extensions.$_pkgname.gschema.xml" -t \
+ install -Dm644 "$_uuid/schemas/org.gnome.shell.extensions.multi-monitors-add-on.gschema.xml" -t \
"$pkgdir/usr/share/glib-2.0/schemas/"
- rm -rf "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/schemas/"
- rm "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/$_pkgname.pot"
+ for lang in de es fr it pl pt_BR; do
+ install -Dm644 "locale/${lang}/LC_MESSAGES/multi-monitors-add-on.mo" -t \
+ "$pkgdir/usr/share/locale/${lang}/LC_MESSAGES/"
+ done
+
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/$_uuid"/{locale,schemas}
+ rm "$pkgdir/usr/share/gnome-shell/extensions/$_uuid/multi-monitors-add-on.pot"
}