summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsmcdougall2017-05-24 10:24:06 -0400
committersmcdougall2017-05-24 10:24:06 -0400
commit19f8da4393a91a85f428806d75b4af83523605f8 (patch)
tree24e285833febb2a11cbe11c4081d3ef97c51b252
parent35137690ef430c0e929cd6904cbdb481805a82c4 (diff)
downloadaur-19f8da4393a91a85f428806d75b4af83523605f8.tar.gz
20170524
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD40
2 files changed, 11 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3102a29ed5d4..c45c0ad4af64 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
-# 2017-05-17
+# Generated by mksrcinfo v8
+# Wed May 24 14:23:24 UTC 2017
pkgbase = gnome-shell-extension-multi-monitors-add-on-git
pkgdesc = Extension inspired by https://github.com/darkxst/multiple-monitor-panels and rewritten from scratch for gnome-shell version 3.10.4. Adds panels and thumbnails for additional monitors. Settings changes are applied in dynamic fashion, no restart needed.
- pkgver = 20170517
+ pkgver = 20170524
pkgrel = 1
url = https://github.com/spin83/multi-monitors-add-on
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 635b02c92dc1..7a27f44a94d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
#Maintainer: smcdougall <simon at sjmcdougall dot com>
pkgname=gnome-shell-extension-multi-monitors-add-on-git
-pkgver=20170517
+pkgver=20170524
pkgrel=1
pkgdesc="Extension inspired by https://github.com/darkxst/multiple-monitor-panels and rewritten from scratch for gnome-shell version 3.10.4. Adds panels and thumbnails for additional monitors. Settings changes are applied in dynamic fashion, no restart needed."
arch=('any')
@@ -10,7 +10,6 @@ license=('GPL2')
depends=('gnome-shell')
makedepends=('git')
groups=('gnome-shell-extensions')
-#install=multi-monitors-add-on.install
_gitroot="git://github.com/spin83/multi-monitors-add-on.git"
_gitname="multi-monitors-add-on"
@@ -32,38 +31,15 @@ build() {
package() {
uuid="multi-monitors-add-on@spin83"
cd "${srcdir}/${_gitname}"
- install -Dm644 "${uuid}/metadata.json" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/metadata.json"
- install -m644 "${uuid}/extension.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/extension.js"
- install -m644 "${uuid}/convenience.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/convenience.js"
- install -m644 "${uuid}/prefs.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/prefs.js"
- install -m644 "${uuid}/indicator.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/indicator.js"
- install -m644 "${uuid}/mmlayout.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/mmlayout.js"
- install -m644 "${uuid}/mmoverview.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/mmoverview.js"
- install -m644 "${uuid}/mmpanel.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/mmpanel.js"
- install -m644 "${uuid}/multi-monitors-add-on.pot" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/multi-monitors-add-on.pot"
- install -m644 "${uuid}/stylesheet.css" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/stylesheet.css"
-
- install -Dm644 "${uuid}/icons/multi-monitors-l-symbolic.svg" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/icons/multi-monitors-l-symbolic.svg"
- install -m644 "${uuid}/icons/multi-monitors-r-symbolic.svg" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/icons/multi-monitors-r-symbolic.svg"
-
- install -Dm644 "${uuid}/locale/de/LC_MESSAGES/multi-monitors-add-on.mo" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/locale/de/LC_MESSAGES/multi-monitors-add-on.mo"
- install -m644 "${uuid}/locale/de/LC_MESSAGES/multi-monitors-add-on.po" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/locale/de/LC_MESSAGES/multi-monitors-add-on.po"
install -Dm644 "${uuid}/schemas/org.gnome.shell.extensions.multi-monitors-add-on.gschema.xml" \
"${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.multi-monitors-add-on.gschema.xml"
+
+ install -dm644 "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/"
+
+ cp -a "${uuid}/" "${pkgdir}/usr/share/gnome-shell/extensions/"
+
+ rm -rf "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/schemas"
+
}