summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Wagner2019-05-11 12:07:20 +0200
committerTom Wagner2019-05-11 12:07:20 +0200
commit8cd81ef1415a380db2c2f3a917689111fda5dd5b (patch)
tree0d1d50c13de87c5b3bf84fb46e9c96b33ff7848c
parenta28f8e4352b421bef96194d44604dbaff43d5eed (diff)
downloadaur-8cd81ef1415a380db2c2f3a917689111fda5dd5b.tar.gz
Update PKGBUILD to fetch newest commit and bumb version automatically.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD25
2 files changed, 10 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d36ca23b1d91..cff43d623e14 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-multi-monitors-add-on-git
pkgdesc = Updated for Gnome 3.32. Adds panels and thumbnails for additional monitors. Settings changes are applied in dynamic fashion, no restart needed.
- pkgver = 20190511
+ pkgver = r82.d72eb2d
pkgrel = 1
url = https://github.com/spin83/multi-monitors-add-on
arch = any
@@ -8,6 +8,8 @@ pkgbase = gnome-shell-extension-multi-monitors-add-on-git
license = GPL2
makedepends = git
depends = gnome-shell
+ source = gnome-shell-extension-multi-monitors-add-on-git::git+https://github.com/spin83/multi-monitors-add-on.git#branch=master
+ md5sums = SKIP
pkgname = gnome-shell-extension-multi-monitors-add-on-git
diff --git a/PKGBUILD b/PKGBUILD
index db8f1b5ad9b8..6e662764b77a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,26 @@
# Contributor: smcdougall <simon at sjmcdougall dot com>
pkgname=gnome-shell-extension-multi-monitors-add-on-git
-pkgver=20190511
+pkgver=r82.d72eb2d
pkgrel=1
pkgdesc="Updated for Gnome 3.32. Adds panels and thumbnails for additional monitors. Settings changes are applied in dynamic fashion, no restart needed."
arch=('any')
url="https://github.com/spin83/multi-monitors-add-on"
+source=("${pkgname}::git+https://github.com/spin83/multi-monitors-add-on.git#branch=master")
+md5sums=(SKIP)
license=('GPL2')
depends=('gnome-shell')
makedepends=('git')
groups=('gnome-shell-extensions')
-_gitroot="git://github.com/spin83/multi-monitors-add-on.git"
-_gitname="multi-monitors-add-on"
-
-build() {
- cd "${srcdir}"
- msg "Connecting to GIT server...."
-
- if [ -d $_gitname ] ; then
- cd $_gitname && git pull origin
- msg "The local files are updated."
- else
- git clone $_gitroot $_gitname
- fi
-
- msg "GIT checkout done or server timeout"
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
uuid="multi-monitors-add-on@spin83"
- cd "${srcdir}/${_gitname}"
+ cd "${srcdir}/${pkgname}/"
install -Dm644 "${uuid}/schemas/org.gnome.shell.extensions.multi-monitors-add-on.gschema.xml" \
"${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.multi-monitors-add-on.gschema.xml"
@@ -41,6 +31,5 @@ package() {
cp -a "${uuid}/" "${pkgdir}/usr/share/gnome-shell/extensions/"
rm -rf "${pkgdir}/usr/share/gnome-shell/extensions/${uuid}/schemas"
-
}