summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBert Peters2018-10-02 15:00:33 +0200
committerBert Peters2018-10-02 15:00:33 +0200
commit594cca69a015d02c17f8765fb4b47ec35a53b896 (patch)
tree3e9d2c3dec78988e6c1ed09d683f4261933fbcc7
downloadaur-594cca69a015d02c17f8765fb4b47ec35a53b896.tar.gz
Initial version.
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ba9d1cb81201
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-shell-extension-netctl-auto-gnome-git
+ pkgdesc = Allows you to switch between netctl profiles using a menu in the GNOME notification area.
+ pkgver = r27.80a54b6
+ pkgrel = 1
+ url = https://github.com/nigeil/netctl-auto-gnome
+ arch = any
+ license = unknown
+ makedepends = git
+ depends = gnome-shell
+ depends = netctl
+ depends = wpa_actiond
+ provides = gnome-shell-extension-netctl-auto-gnome
+ conflicts = gnome-shell-extension-netctl-auto-gnome
+ source = gnome-shell-extension-netctl-auto-gnome::git+https://github.com/nigeil/netctl-auto-gnome.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-netctl-auto-gnome-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e78719d6844
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Bert Peters <bert@bertptrs.nl>
+pkgname='gnome-shell-extension-netctl-auto-gnome-git'
+pkgver=r27.80a54b6
+pkgrel=1
+pkgdesc='Allows you to switch between netctl profiles using a menu in the GNOME notification area.'
+arch=(any)
+url="https://github.com/nigeil/netctl-auto-gnome"
+license=('unknown')
+depends=('gnome-shell' 'netctl' 'wpa_actiond')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+https://github.com/nigeil/netctl-auto-gnome.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ local ext_name='netctl-auto-gnome@nigelmichki.ninja'
+ install -Dm644 -t "$pkgdir/usr/share/gnome-shell/extensions/$ext_name" "$ext_name/"*
+}