summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRanieri Althoff2019-10-28 03:04:48 -0300
committerRanieri Althoff2019-10-28 03:04:48 -0300
commit3b78d5a1dfaf26bd0053c1fc48dc07c7b7030c22 (patch)
treee92c4b7a5b57c45c30717f6aecf8cec52b12df6d
downloadaur-3b78d5a1dfaf26bd0053c1fc48dc07c7b7030c22.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD28
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60161f07e359
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-no-annoyance-git
+ pkgdesc = Removes the “Windows is ready” notification and puts the window into focus
+ pkgver = r5.f21d09a
+ pkgrel = 1
+ url = https://github.com/sindex/no-annoyance
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = zip
+ depends = gnome-shell>=3.18
+ provides = gnome-shell-extension-no-annoyance
+ conflicts = gnome-shell-extension-no-annoyance
+ source = gnome-shell-extension-no-annoyance-git::git+https://github.com/sindex/no-annoyance.git
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-no-annoyance-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccdadf693590
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8aca50066d5c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ranieri Althoff <ranisalt+aur at gmail dot com>
+
+pkgname=gnome-shell-extension-no-annoyance-git
+pkgver=r5.f21d09a
+pkgrel=1
+pkgdesc='Removes the “Windows is ready” notification and puts the window into focus'
+url='https://github.com/sindex/no-annoyance'
+license=('GPL2')
+arch=('any')
+conflicts=(${pkgname%-git})
+provides=(${pkgname%-git})
+makedepends=('git' 'zip')
+depends=('gnome-shell>=3.18')
+source=("${pkgname}::git+${url}.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ destdir="$pkgdir/usr/share/gnome-shell/extensions/$uuid"
+ install -dm755 "$destdir"
+ install -Dm644 extension.js metadata.json "$destdir"
+}