summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex S2017-11-19 22:41:05 +0100
committerAlex S2017-11-19 22:41:05 +0100
commit4572d480662980e96b4fc7eae9ebb3de746b574b (patch)
tree369b8aa5ef8d8c30b0a213daee51421d8d9d8a09
parent83b1cd155a3fd8986818f3ee346e4a8108b96665 (diff)
downloadaur-4572d480662980e96b4fc7eae9ebb3de746b574b.tar.gz
Update to v6.r9.g05e740e
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96b5d597c182..eb2eca9d10d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-no-title-bar
pkgdesc = No Title Bar removes the title bar, moves the window title and buttons to the top panel.
- pkgver = v6.r6.gb2724e9
+ pkgver = v6.r9.g05e740e
pkgrel = 0
url = https://github.com/franglais125/no-title-bar
install = gnome-shell-extension-no-title-bar.install
diff --git a/PKGBUILD b/PKGBUILD
index 53f20ff44a55..dc3be0513d58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=gnome-shell-extension-no-title-bar
_gitname=no-title-bar
-pkgver=v6.r6.gb2724e9
+pkgver=v6.r9.g05e740e
pkgrel=0
pkgdesc="No Title Bar removes the title bar, moves the window title and buttons to the top panel."
arch=('any')
@@ -17,16 +17,17 @@ source=('git://github.com/franglais125/no-title-bar.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${_gitname}"
+ cd "${srcdir}/${_gitname}"
git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/${_gitname}"
+ _extid="no-title-bar@franglais125.gmail.com"
+ cd "${srcdir}/${_gitname}"
make _build
mv _build no-title-bar@franglais125.gmail.com
install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname%-*}"
install -d "${pkgdir}/usr/share/gnome-shell/extensions"
- cp -af "no-title-bar@franglais125.gmail.com" "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cp -af "${_extid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
}