summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex S2017-10-20 18:37:17 +0200
committerAlex S2017-10-20 18:37:17 +0200
commit4d82ef944b0b58d32db77f6b98e737ff03f4ccd1 (patch)
treeb07d8a42eac80f0d50aa82185e20ea4d51f5b9d5
downloadaur-4d82ef944b0b58d32db77f6b98e737ff03f4ccd1.tar.gz
First try
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--gnome-shell-extension-no-title-bar.install7
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3771f6f51e7b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = gnome-shell-extension-no-title-bar
+ pkgdesc = No Title Bar removes the title bar, moves the window title and buttons to the top panel.
+ pkgver = 6.r6.gb2724e9
+ pkgrel = 0
+ url = https://github.com/franglais125/no-title-bar
+ install = gnome-shell-extension-no-title-bar.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell
+ depends = xorg-xprop
+ provides = gnome-shell-extension-no-title-bar
+ conflicts = gnome-shell-extension-no-title-bar
+ conflicts = gnome-shell-extension-pixel-saver
+ conflicts = gnome-shell-extension-pixel-saver-git
+ source = git://github.com/franglais125/no-title-bar.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-no-title-bar
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..72977138bc53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Alex S. shantanna_at_hotmail_dot_com>
+
+pkgname=gnome-shell-extension-no-title-bar
+_gitname=no-title-bar
+pkgver=6.r6.gb2724e9
+pkgrel=0
+pkgdesc="No Title Bar removes the title bar, moves the window title and buttons to the top panel."
+arch=('any')
+url="https://github.com/franglais125/no-title-bar"
+license=('GPL2')
+depends=('gnome-shell' 'xorg-xprop')
+makedepends=('git')
+provides=('gnome-shell-extension-no-title-bar')
+conflicts=('gnome-shell-extension-no-title-bar' 'gnome-shell-extension-pixel-saver' 'gnome-shell-extension-pixel-saver-git')
+install=${pkgname}.install
+source=('git://github.com/franglais125/no-title-bar.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_gitname}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$srcdir/${_gitname}"
+ make _build
+ mv _build no-title-bar@franglais125.gmail.com
+
+ install -Dm644 COPYING -t "${pkgdir}/usr/share/licenses/${pkgname%-*}"
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+ cp -af "no-title-bar@franglais125.gmail.com" "${pkgdir}/usr/share/gnome-shell/extensions/"
+}
diff --git a/gnome-shell-extension-no-title-bar.install b/gnome-shell-extension-no-title-bar.install
new file mode 100644
index 000000000000..f9b300addb0c
--- /dev/null
+++ b/gnome-shell-extension-no-title-bar.install
@@ -0,0 +1,7 @@
+post_install() {
+ echo ''
+ echo '==> To enable no-title-bar:'
+ echo '==> Reload Gnome Shell with Alt-F2 r'
+ echo '==> Enable it with gnome-tweak-tool or "gnome-shell-extension-tool -e no-title-bar@franglais125.gmail.com"'
+ echo ''
+}