summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorColin Wallace2015-10-04 18:57:58 -0700
committerColin Wallace2015-10-04 19:01:15 -0700
commitf525b014e9fae6be1f1c318dac2fcda9b4866328 (patch)
tree9096685fb7928a62749f43b894191509164fd502
downloadaur-f525b014e9fae6be1f1c318dac2fcda9b4866328.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD29
-rw-r--r--notice.install15
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a547d4b1287d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-nohotcorner-git
+ pkgdesc = Gnome-shell extension disabling hotcorners
+ pkgver = 11.0.r4.ge300475
+ pkgrel = 1
+ url = https://github.com/HROMANO/nohotcorner
+ arch = any
+ license = GPLv2
+ makedepends = git
+ depends = gnome-shell
+ source = git://github.com/HROMANO/nohotcorner.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-nohotcorner-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..928eb5c07b77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Colin Wallace <wallacoloo@gmail.com>
+
+pkgname=gnome-shell-extension-nohotcorner-git
+_gitname=nohotcorner
+pkgver=11.0.r4.ge300475
+pkgrel=1
+pkgdesc="Gnome-shell extension disabling hotcorners"
+arch=('any')
+url="https://github.com/HROMANO/nohotcorner"
+license=('GPLv2')
+depends=('gnome-shell')
+makedepends=('git')
+source=('git://github.com/HROMANO/nohotcorner.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ _uuid='nohotcorner@azuri.free.fr'
+
+ cd "$_gitname"
+ install -Dm644 "metadata.json" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
+ install -m644 "extension.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
+}
diff --git a/notice.install b/notice.install
new file mode 100644
index 000000000000..bac60d6e7b45
--- /dev/null
+++ b/notice.install
@@ -0,0 +1,15 @@
+post_install() {
+ instruct
+ echo "and enable the extension with gnome-tweak-tool."
+}
+
+post_upgrade() {
+ instruct
+ echo "for the changes to have an effect."
+}
+
+instruct() {
+ echo "Don't forget to restart GNOME Shell ([Alt]+[F2], r)"
+}
+
+# vim: ts=2 sw=2 et: