summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJussi Saarinen2015-07-07 22:20:25 +0300
committerJussi Saarinen2015-07-07 22:20:25 +0300
commit415165622e7f4419ab37d343d9046366c410afbc (patch)
tree8c57445b26b183f2412a6700ffe5bacb577ec3dd
downloadaur-415165622e7f4419ab37d343d9046366c410afbc.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD37
-rw-r--r--gschemas.install42
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0c565637866e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = gnome-shell-extension-openweather-git
+ pkgdesc = A simple extension for displaying weather informations from several cities in GNOME Shell.
+ pkgver = r729.9d0b1b1
+ pkgrel = 1
+ url = https://github.com/jenslody/gnome-shell-extension-openweather
+ install = gschemas.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ makedepends = gnome-common
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = intltool
+ depends = glib2
+ depends = gettext
+ depends = pkg-config
+ provides = gnome-shell-extension-weather-neroth-git
+ provides = gnome-shell-extension-weather-git
+ provides = gnome-shell-extension-yawe-git
+ conflicts = gnome-shell-extension-weather-neroth-git
+ conflicts = gnome-shell-extension-weather-git
+ conflicts = gnome-shell-extension-yawe-git
+ source = gnome-shell-extension-openweather-git::git+https://github.com/jenslody/gnome-shell-extension-openweather#branch=master
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-openweather-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c2db1471f15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: jtts
+# Contributor: Christian METZLER <neroth@xeked.com>
+
+pkgname=gnome-shell-extension-openweather-git
+pkgver=r729.9d0b1b1
+pkgrel=1
+pkgdesc="A simple extension for displaying weather informations from several cities in GNOME Shell."
+arch=(any)
+url="https://github.com/jenslody/gnome-shell-extension-openweather"
+license=(GPL3)
+depends=(glib2 gettext pkg-config)
+makedepends=(git gnome-common autoconf automake intltool)
+provides=(gnome-shell-extension-weather-neroth-git
+ gnome-shell-extension-weather-git
+ gnome-shell-extension-yawe-git)
+conflicts=(gnome-shell-extension-weather-neroth-git
+ gnome-shell-extension-weather-git
+ gnome-shell-extension-yawe-git)
+install='gschemas.install'
+source=("$pkgname"::"git+https://github.com/jenslody/gnome-shell-extension-openweather#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR=$pkgdir install
+} \ No newline at end of file
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..2fbf27d8628d
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,42 @@
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_install
+}
+
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_upgrade
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+instructions_install() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r).
+Active the extension with gnome-tweak-tool.
+Configure with the Weather Settings button.
+For more informations, see https://github.com/jenslody/gnome-shell-extension-openweather
+
+EOF
+}
+
+instructions_upgrade() {
+ /bin/cat << EOF
+
+Just restart GNOME Shell ([Alt]+[F2], r).
+What new ?
+ * Currently, the weather data is fetched from OpenWeatherMap (including
+ forecasts for up to ten days) or forecast.io (including forecasts for
+ up to eight days).
+ * Note: since version 29 this extensions uses coordinates to store the
+ locations and makes the names editable to support multiple
+ weather-providers! If you update from versions prior to 29 to 29 or greater
+ (with forecast.io - support) you have to recreate your locations.
+
+For more informations, see https://github.com/jenslody/gnome-shell-extension-openweather
+
+EOF
+}