summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2022-08-27 11:51:38 +0200
committerChristian Schendel2022-08-27 11:51:38 +0200
commit2dafcef239b83612bd3a4ce85a42853b7e6c2f9c (patch)
treea940f98b744c58245133e03c7da795e5cb64dcb4
downloadaur-2dafcef239b83612bd3a4ce85a42853b7e6c2f9c.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
-rwxr-xr-xgnome-shell-extension-pano.install30
4 files changed, 109 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..19cf479c4355
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = gnome-shell-extension-pano-git
+ pkgdesc = Next-gen Clipboard Manager
+ pkgver = 3.r0.gb93936f
+ pkgrel = 1
+ url = https://github.com/oae/gnome-shell-pano
+ install = gnome-shell-extension-pano.install
+ arch = any
+ groups = gnome-shell-extensions
+ license = GPL
+ makedepends = git
+ makedepends = glib2
+ makedepends = yarn
+ makedepends = appstream
+ depends = gnome-shell>=42
+ provides = gnome-shell-extension-pano
+ conflicts = gnome-shell-extension-pano
+ options = !strip
+ source = gnome-shell-extension-pano::git+https://github.com/oae/gnome-shell-pano.git
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-pano-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..833085309a2e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.zst
+*/*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3159eb07d698
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Christian Schendel (doppelhelix@gmail.com)
+
+pkgname=gnome-shell-extension-pano-git
+pkgver=3.r0.gb93936f
+pkgrel=1
+pkgdesc="Next-gen Clipboard Manager"
+arch=('any')
+url="https://github.com/oae/gnome-shell-pano"
+install=${pkgname%-git}.install
+license=('GPL')
+groups=('gnome-shell-extensions')
+depends=('gnome-shell>=42')
+makedepends=('git'
+ 'glib2'
+ 'yarn'
+ 'appstream')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("${pkgname%-git}::git+${url}.git")
+options=('!strip')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${pkgname%-git}"
+ yarn install
+}
+
+build() {
+ cd "${srcdir}/${pkgname%-git}"
+ yarn build
+
+}
+
+package() {
+ cd "${srcdir}/${pkgname%-git}/dist"
+ local uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ local schema=org.gnome.shell.extensions.extensions-sync.gschema.xml
+ local destdir="${pkgdir}/usr/share/gnome-shell/extensions/${uuid}"
+ install -dm755 "${destdir}"
+ find . -regextype posix-egrep -regex ".*\.(js|json|xml|css|mo|compiled|svg|png)$" -exec\
+ install -Dm 644 {} ${destdir}/{} \;
+ install -Dm644 "${srcdir}/${pkgname%-git}/dist/schemas/${schema}" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
+# rebuild compiled GSettings schemas if missing
+ if [[ ! -f "${destdir}/schemas/gschemas.compiled" ]]; then
+ glib-compile-schemas "${destdir}/schemas"
+ fi
+}
+
diff --git a/gnome-shell-extension-pano.install b/gnome-shell-extension-pano.install
new file mode 100755
index 000000000000..7f4546e45017
--- /dev/null
+++ b/gnome-shell-extension-pano.install
@@ -0,0 +1,30 @@
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_install
+}
+
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_upgrade
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+instructions_install() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r).
+Activate the extension with gnome-tweak-tool.
+
+EOF
+}
+
+instructions_upgrade() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
+
+EOF
+}