summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Schendel2023-03-27 02:38:00 +0200
committerChristian Schendel2023-03-27 02:38:00 +0200
commitd0035c3f4f554a9309716692fb761d570576c4ad (patch)
treee0e2b66709f040bc3d9e881ee4051bbec7851a09
parent5b989f3d93a8139b5bc65bb24731a19a90671818 (diff)
downloadaur-d0035c3f4f554a9309716692fb761d570576c4ad.tar.gz
removed .install file
removed gnome-shell-extensions group removed glib2 makedepends removed stripping moved gobject-introspection to makedepends removed glib-compile-schemas moved locale to /usr/share removed schemas directory
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rwxr-xr-xgnome-shell-extension-pano.install30
3 files changed, 8 insertions, 49 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 598b523dbd75..27c97818f3a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,20 @@
pkgbase = gnome-shell-extension-pano-git
pkgdesc = Next-gen Clipboard Manager
- pkgver = 10.r23.gac43c48
- pkgrel = 2
+ pkgver = 19.r15.g7c6e931
+ pkgrel = 1
url = https://github.com/oae/gnome-shell-pano
- install = gnome-shell-extension-pano.install
arch = any
- groups = gnome-shell-extensions
license = GPL
makedepends = git
- makedepends = glib2
+ makedepends = gobject-introspection
makedepends = yarn
makedepends = appstream
depends = gnome-shell>=1:42
depends = libgda6
- depends = gobject-introspection
depends = cogl
depends = gsound
provides = gnome-shell-extension-pano
conflicts = gnome-shell-extension-pano
- options = !strip
source = gnome-shell-extension-pano::git+https://github.com/oae/gnome-shell-pano.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2acadbdb2f51..3bbe5e3dca8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,23 @@
# Maintainer: Christian Schendel (doppelhelix@gmail.com)
pkgname=gnome-shell-extension-pano-git
-pkgver=10.r23.gac43c48
-pkgrel=2
+pkgver=19.r15.g7c6e931
+pkgrel=1
pkgdesc="Next-gen Clipboard Manager"
arch=('any')
url="https://github.com/oae/gnome-shell-pano"
-install=${pkgname%-git}.install
license=('GPL')
-groups=('gnome-shell-extensions')
depends=('gnome-shell>=1:42'
'libgda6'
- 'gobject-introspection'
'cogl'
'gsound')
makedepends=('git'
- 'glib2'
+ 'gobject-introspection'
'yarn'
'appstream')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("${pkgname%-git}::git+${url}.git")
-options=('!strip')
md5sums=('SKIP')
pkgver() {
@@ -46,13 +42,10 @@ package() {
local schema=$(grep -Po '(?<="settings-schema": ")[^"]*' metadata.json).gschema.xml
local destdir="${pkgdir}/usr/share/gnome-shell/extensions/${uuid}"
install -dm755 "${destdir}"
- find . -regextype posix-egrep -regex ".*\.(js|json|xml|css|mo|compiled|svg|png)$" -exec\
+ find . -regextype posix-egrep -regex ".*\.(js|json|xml|css|compiled|svg|png)$" -exec\
install -Dm 644 {} ${destdir}/{} \;
install -Dm644 "${srcdir}/${pkgname%-git}/dist/schemas/${schema}" \
"${pkgdir}/usr/share/glib-2.0/schemas/${schema}"
-# rebuild compiled GSettings schemas if missing
- if [[ ! -f "${destdir}/schemas/gschemas.compiled" ]]; then
- glib-compile-schemas "${destdir}/schemas"
- fi
+ cp -r "${srcdir}/${pkgname%-git}/dist/locale" "$pkgdir/usr/share/"
}
diff --git a/gnome-shell-extension-pano.install b/gnome-shell-extension-pano.install
deleted file mode 100755
index 7f4546e45017..000000000000
--- a/gnome-shell-extension-pano.install
+++ /dev/null
@@ -1,30 +0,0 @@
-post_install() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_install
-}
-
-post_upgrade() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_upgrade
-}
-
-post_remove() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
-}
-
-instructions_install() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r).
-Activate the extension with gnome-tweak-tool.
-
-EOF
-}
-
-instructions_upgrade() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
-
-EOF
-}