summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2022-12-19 18:54:31 +0330
committerMohammadreza Abdollahzadeh2022-12-19 18:54:31 +0330
commit0b800438096edad42ca844572628cb79057ae6c0 (patch)
treecaecf10d7f962aad7fe86a74d0f98994c2cb5993
parent96c3b2d7e5987be98edcfe22c4248c013a9dac5e (diff)
downloadaur-0b800438096edad42ca844572628cb79057ae6c0.tar.gz
upgpkg: gnome-shell-extension-persian-calendar-git r318.6ba3922-1
Fix building instructions
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD32
-rw-r--r--gnome-shell-extension-persian-calendar.install12
-rw-r--r--gnome-shell-extension.install17
4 files changed, 34 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e5a37d8a9236..4554306b73a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = gnome-shell-extension-persian-calendar-git
- pkgdesc = Persian calendar for Gnome Shell.
- pkgver = r155.362532a
+ pkgdesc = An extension for Gnome-Shell to show Persian date and calendar.
+ pkgver = r318.6ba3922
pkgrel = 1
url = https://github.com/omid/Persian-Calendar-for-Gnome-Shell
- install = gnome-shell-extension.install
+ install = gnome-shell-extension-persian-calendar.install
arch = any
license = GPL3
makedepends = git
- depends = gnome-shell>=3.24
+ depends = gnome-shell>=40
+ optdepends = vazirmatn-fonts: to use as default Persian font.
provides = gnome-shell-extension-persian-calendar
conflicts = gnome-shell-extension-persian-calendar
- replaces = gnome-shell-extension-persian-calendar
source = gnome-shell-extension-persian-calendar::git+https://github.com/omid/Persian-Calendar-for-Gnome-Shell
sha256sums = SKIP
pkgname = gnome-shell-extension-persian-calendar-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 5af0c3131416..1c13b4ab0ce1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,35 @@
# Maintainer: Omid Mottaghi Rad <omidmr at gmail dot com>
-# Co-Maintainer: M A <morealaz at gmail dot com>
-
+# Co-Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
pkgname=gnome-shell-extension-persian-calendar-git
-pkgver=r155.362532a
+pkgver=r318.6ba3922
pkgrel=1
-pkgdesc="Persian calendar for Gnome Shell."
+pkgdesc="An extension for Gnome-Shell to show Persian date and calendar."
arch=(any)
url="https://github.com/omid/Persian-Calendar-for-Gnome-Shell"
license=(GPL3)
-depends=('gnome-shell>=3.24')
+depends=('gnome-shell>=40')
+makedepends=('git')
+optdepends=('vazirmatn-fonts: to use as default Persian font.')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-replaces=("${pkgname%-git}")
-makedepends=(git)
-install='gnome-shell-extension.install'
-source=("${pkgname%-git}"::"git+https://github.com/omid/Persian-Calendar-for-Gnome-Shell")
+install="${pkgname%-git}.install"
+source=("${pkgname%-git}::git+${url}")
sha256sums=('SKIP')
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ sed -i 's|\binstall_fonts();||g' 'PersianCalendar@oxygenws.com/extension.js'
+ sed -i 's|\buninstall_fonts();||g' 'PersianCalendar@oxygenws.com/extension.js'
+ sed -i 's|Vazir,|Vazirmatn,|g' 'PersianCalendar@oxygenws.com/stylesheet.css'
+}
+
pkgver() {
cd "$srcdir/${pkgname%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
}
package() {
- install -d "${pkgdir}/usr/share/gnome-shell/extensions/"
- cp -a "${pkgname%-git}/PersianCalendar@oxygenws.com" \
- "${pkgdir}/usr/share/gnome-shell/extensions/"
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="${pkgdir}" install-local
}
# vim:set ts=4 sw=4 et:
diff --git a/gnome-shell-extension-persian-calendar.install b/gnome-shell-extension-persian-calendar.install
new file mode 100644
index 000000000000..3e5863ead2e6
--- /dev/null
+++ b/gnome-shell-extension-persian-calendar.install
@@ -0,0 +1,12 @@
+post_install() {
+ echo ''
+ echo '==> To enable Persian Calendar extension:'
+ echo '==> Reload Gnome Shell with Alt-F2 r (on Xorg), logout -> login (wayland)'
+ echo '==> Enable it with the extensions tool'
+ echo '==> or run "gnome-extensions enable PersianCalendar@oxygenws.com"'
+ echo ''
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
deleted file mode 100644
index d78a7a1584a4..000000000000
--- a/gnome-shell-extension.install
+++ /dev/null
@@ -1,17 +0,0 @@
-post_install() {
- echo ""
- echo "*********************************************************"
- echo "* Don't forget to enable this extension in GNOME Tweaks *"
- echo "* and *"
- echo "* restart GNOME Shell ([Alt]+[F2], r) *"
- echo "*********************************************************"
- echo ""
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}