summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmid Mottaghi Rad2018-10-09 20:19:39 +0200
committerOmid Mottaghi Rad2018-10-09 20:19:39 +0200
commit1db1af3da115d29a9bf2ca033935857175de3197 (patch)
tree578df1258c0fedc0b8ba3ab7384006a979bc73b9
parente3bc13739ba9300f2bb0dad42a57956495e4a091 (diff)
downloadaur-1db1af3da115d29a9bf2ca033935857175de3197.tar.gz
Removing install dir before installing a new version
-rw-r--r--PKGBUILD3
-rw-r--r--gnome-shell-extension.install10
2 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 036fd8c9c38c..fb338aa55db2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,7 +27,8 @@ pkgver() {
package() {
install -d "${pkgdir}/usr/share/gnome-shell/extensions/"
+ rm -rf "${pkgdir}/usr/share/gnome-shell/extensions/PersianCalendar@oxygenws.com"
cp -a "${pkgname%-git}/PersianCalendar@oxygenws.com" \
- "${pkgdir}/usr/share/gnome-shell/extensions/PersianCalendar@oxygenws.com"
+ "${pkgdir}/usr/share/gnome-shell/extensions/"
}
# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
index 484bc1b03f77..d78a7a1584a4 100644
--- a/gnome-shell-extension.install
+++ b/gnome-shell-extension.install
@@ -1,7 +1,11 @@
post_install() {
- echo "==> ****************************************************"
- echo "==> Don't forget to Restart GNOME Shell ([Alt]+[F2], r)."
- echo "==> ****************************************************"
+ echo ""
+ echo "*********************************************************"
+ echo "* Don't forget to enable this extension in GNOME Tweaks *"
+ echo "* and *"
+ echo "* restart GNOME Shell ([Alt]+[F2], r) *"
+ echo "*********************************************************"
+ echo ""
}
post_upgrade() {