summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-04-26 22:34:35 +0430
committerMohammadreza Abdollahzadeh2017-04-26 22:34:35 +0430
commitc4cd0499cda2061fee43206f86f3027f7cccb690 (patch)
tree38392b25f101e6dc4cc9d275dc3f276537d1117d
downloadaur-c4cd0499cda2061fee43206f86f3027f7cccb690.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--gnome-shell-extension.install29
3 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34caa332e4c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Wed Apr 26 18:04:13 UTC 2017
+pkgbase = gnome-shell-extension-persian-calendar-git
+ pkgdesc = Persian calendar for Gnome Shell.
+ pkgver = r124.6729756
+ pkgrel = 1
+ url = https://github.com/omid/Persian-Calendar-for-Gnome-Shell
+ install = gnome-shell-extension.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell>=3.20
+ provides = gnome-shell-extension-persian-calendar
+ conflicts = gnome-shell-extension-persian-calendar
+ replaces = gnome-shell-extension-persian-calendar
+ source = gnome-shell-extension-persian-calendar::git+https://github.com/omid/Persian-Calendar-for-Gnome-Shell
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-persian-calendar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f5b512e220df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Omid Mottaghi Rad <omidmr at gmail dot com>
+# Co-Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=gnome-shell-extension-persian-calendar-git
+pkgver=r124.6729756
+pkgrel=1
+pkgdesc="Persian calendar for Gnome Shell."
+arch=(any)
+url="https://github.com/omid/Persian-Calendar-for-Gnome-Shell"
+license=(GPL3)
+depends=('gnome-shell>=3.20')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=("${pkgname%-git}")
+makedepends=(git)
+install='gnome-shell-extension.install'
+source=("${pkgname%-git}"::"git+https://github.com/omid/Persian-Calendar-for-Gnome-Shell")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/PersianCalendar@oxygenws.com"
+ cp -a $srcdir/${pkgname%-git}/* "$pkgdir/usr/share/gnome-shell/extensions/PersianCalendar@oxygenws.com"
+ rm -rf $pkgdir/usr/share/gnome-shell/extensions/PersianCalendar@oxygenws.com/.git
+}
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
new file mode 100644
index 000000000000..071e836c8cfa
--- /dev/null
+++ b/gnome-shell-extension.install
@@ -0,0 +1,29 @@
+post_install() {
+ instructions_install
+}
+
+post_upgrade() {
+ instructions_upgrade
+}
+
+instructions_install() {
+ # list enabled extensions
+ EXTENSION_LIST=$(gsettings get org.gnome.shell enabled-extensions | sed 's/^.\(.*\).$/\1/')
+
+ # check if extension is already enabled
+ EXTENSION_ENABLED=$(echo ${EXTENSION_LIST} | grep 'PersianCalendar@oxygenws.com')
+
+ if [ "$EXTENSION_ENABLED" = "" ]
+ then
+ # enable extension
+ gsettings set org.gnome.shell enabled-extensions "[${EXTENSION_LIST},'${EXTENSION_UUID}']"
+ fi
+
+ echo "*** Restart GNOME Shell ([Alt]+[F2], r)."
+ echo "*** For more informations, see https://github.com/omid/Persian-Calendar-for-Gnome-Shell."
+}
+
+instructions_upgrade() {
+ echo "*** Restart GNOME Shell ([Alt]+[F2], r)."
+ echo "*** For more informations, see https://github.com/omid/Persian-Calendar-for-Gnome-Shell."
+}