summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-10-13 08:09:53 -0600
committerMark Wagie2023-10-13 08:09:53 -0600
commit152a906bc16348378e461c432b2a18b36f0afed4 (patch)
tree19694a600b1c6a709dbf1a41a780062cf6893c20
parent621da5d3abba1a3ef8bd219569a6fd1f949b6f25 (diff)
downloadaur-152a906bc16348378e461c432b2a18b36f0afed4.tar.gz
switch back to main repo
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 06fed739a964..d09dd26038d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-pop-shell
pkgdesc = GNOME Shell extension for advanced tiling window management
- pkgver = 1.2.0+302+g446e152
+ pkgver = 1.2.0+294+g5b7afc6
pkgrel = 1
url = https://github.com/pop-os/shell
arch = any
@@ -14,7 +14,7 @@ pkgbase = gnome-shell-extension-pop-shell
depends = xorg-xprop
optdepends = gnome-control-center: keybinding categories
optdepends = gnome-shell-extensions: for Native Window Placment extension
- source = git+https://github.com/ronanru/pop-shell-gnome-45.git#commit=446e1520bba99376a04f320880ebd8a63a7a689a
+ source = git+https://github.com/pop-os/shell.git#commit=5b7afc619721ff866507c72b95d65e15a252a1d9
source = 0001-Remove-schema-handling-from-transpile.sh.patch
source = 50_org.gnome.desktop.wm.keybindings.pop-shell.gschema.override
source = 50_org.gnome.mutter.pop-shell.gschema.override
diff --git a/PKGBUILD b/PKGBUILD
index 34748f5be118..7b59b759e567 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Vincent.Ducamps <aur@ducamps.win>
pkgname=gnome-shell-extension-pop-shell
-pkgver=1.2.0+302+g446e152
+pkgver=1.2.0+294+g5b7afc6
pkgrel=1
pkgdesc="GNOME Shell extension for advanced tiling window management"
arch=('any')
@@ -11,8 +11,8 @@ depends=('fd' 'gnome-shell' 'pop-launcher' 'pop-shell-shortcuts' 'xorg-xprop')
makedepends=('typescript' 'git')
optdepends=('gnome-control-center: keybinding categories'
'gnome-shell-extensions: for Native Window Placment extension')
-_commit=446e1520bba99376a04f320880ebd8a63a7a689a # branch/master_jammy
-source=("git+https://github.com/ronanru/pop-shell-gnome-45.git#commit=${_commit}"
+_commit=5b7afc619721ff866507c72b95d65e15a252a1d9 # branch/master_mantic
+source=("git+https://github.com/pop-os/shell.git#commit=${_commit}"
'0001-Remove-schema-handling-from-transpile.sh.patch'
'50_org.gnome.desktop.wm.keybindings.pop-shell.gschema.override'
'50_org.gnome.mutter.pop-shell.gschema.override'
@@ -28,22 +28,22 @@ sha256sums=('SKIP'
'59cf3799036e22718577d0a89468605b6ca1e253d9d7133a8afd640188e2ea9d')
pkgver() {
- cd pop-shell-gnome-45
+ cd shell
git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd pop-shell-gnome-45
+ cd shell
patch -Np1 -i ../0001-Remove-schema-handling-from-transpile.sh.patch
}
build() {
- cd pop-shell-gnome-45
+ cd shell
make
}
package() {
- cd pop-shell-gnome-45
+ cd shell
make DESTDIR="${pkgdir}/" install
# install the schema file