summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-10-12 09:55:33 -0600
committerMark Wagie2023-10-12 09:55:33 -0600
commit621da5d3abba1a3ef8bd219569a6fd1f949b6f25 (patch)
tree675bb2b2891b45613635aea5aab89df4285876b5
parent36b01f89f4a92b74108dc3535098e318893183f8 (diff)
downloadaur-621da5d3abba1a3ef8bd219569a6fd1f949b6f25.tar.gz
switch to GNOME 45 fork
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df5d8c801736..06fed739a964 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gnome-shell-extension-pop-shell
pkgdesc = GNOME Shell extension for advanced tiling window management
- pkgver = 1.2.0+293+gb5accce
+ pkgver = 1.2.0+302+g446e152
pkgrel = 1
url = https://github.com/pop-os/shell
arch = any
@@ -8,13 +8,13 @@ pkgbase = gnome-shell-extension-pop-shell
makedepends = typescript
makedepends = git
depends = fd
- depends = gnome-shell<=1:44.6
+ depends = gnome-shell
depends = pop-launcher
depends = pop-shell-shortcuts
depends = xorg-xprop
optdepends = gnome-control-center: keybinding categories
optdepends = gnome-shell-extensions: for Native Window Placment extension
- source = git+https://github.com/pop-os/shell.git#commit=b5acccefcaa653791d25f70a22c0e04f1858d96e
+ source = git+https://github.com/ronanru/pop-shell-gnome-45.git#commit=446e1520bba99376a04f320880ebd8a63a7a689a
source = 0001-Remove-schema-handling-from-transpile.sh.patch
source = 50_org.gnome.desktop.wm.keybindings.pop-shell.gschema.override
source = 50_org.gnome.mutter.pop-shell.gschema.override
diff --git a/PKGBUILD b/PKGBUILD
index 99da247b11ed..34748f5be118 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,18 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Vincent.Ducamps <aur@ducamps.win>
pkgname=gnome-shell-extension-pop-shell
-pkgver=1.2.0+293+gb5accce
+pkgver=1.2.0+302+g446e152
pkgrel=1
pkgdesc="GNOME Shell extension for advanced tiling window management"
arch=('any')
url="https://github.com/pop-os/shell"
license=('GPL3')
-depends=('fd' 'gnome-shell<=1:44.6' 'pop-launcher' 'pop-shell-shortcuts' 'xorg-xprop')
+depends=('fd' 'gnome-shell' 'pop-launcher' 'pop-shell-shortcuts' 'xorg-xprop')
makedepends=('typescript' 'git')
optdepends=('gnome-control-center: keybinding categories'
'gnome-shell-extensions: for Native Window Placment extension')
-_commit=b5acccefcaa653791d25f70a22c0e04f1858d96e # branch/master_jammy
-source=("git+${url}.git#commit=${_commit}"
+_commit=446e1520bba99376a04f320880ebd8a63a7a689a # branch/master_jammy
+source=("git+https://github.com/ronanru/pop-shell-gnome-45.git#commit=${_commit}"
'0001-Remove-schema-handling-from-transpile.sh.patch'
'50_org.gnome.desktop.wm.keybindings.pop-shell.gschema.override'
'50_org.gnome.mutter.pop-shell.gschema.override'
@@ -26,25 +26,24 @@ sha256sums=('SKIP'
'16a372347d46f9079047557ba09a7a2335e5e64d3fa40118dbc6b0d53d8e686c'
'cb2f53c3c19ed2123373cd3183c3aad1e85d9a661c9e967c6888b7eae3bb18f0'
'59cf3799036e22718577d0a89468605b6ca1e253d9d7133a8afd640188e2ea9d')
-#validpgpkeys=('2A8CB607A1D3332C18E86652B2732D4240C9212C') # Michael Aaron Murphy <michael@system76.com>
pkgver() {
- cd "${srcdir}/shell"
+ cd pop-shell-gnome-45
git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd "${srcdir}/shell"
+ cd pop-shell-gnome-45
patch -Np1 -i ../0001-Remove-schema-handling-from-transpile.sh.patch
}
build() {
- cd "${srcdir}/shell"
+ cd pop-shell-gnome-45
make
}
package() {
- cd "${srcdir}/shell"
+ cd pop-shell-gnome-45
make DESTDIR="${pkgdir}/" install
# install the schema file