summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvincent2020-10-06 19:34:20 +0200
committervincent2020-10-06 19:34:20 +0200
commita223b45c9c56ed80dacd3dda5df50813aef9eeec (patch)
tree27ee48e24e3877729efa5607ecab79956248d6c5
parentb6e9a80709e5c9e4074719f7b67edbcdb6e01ae8 (diff)
downloadaur-a223b45c9c56ed80dacd3dda5df50813aef9eeec.tar.gz
pass .confirm_shortcut_change in post install
-rw-r--r--PKGBUILD1
-rwxr-xr-xpop-shell.install5
2 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5470ccd5bfc..9dc4f9a89a56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,6 +36,5 @@ package() {
cd "${srcdir}/${_dir}"
make DESTDIR="${pkgdir}/" install
install -Dm755 scripts/configure.sh "${pkgdir}/usr/share/gnome-shell/extensions/pop-shell@system76.com/scripts/configure.sh"
- touch "${pkgdir}/usr/share/gnome-shell/extensions/pop-shell@system76.com/scripts/.confirm_shortcut_change"
}
diff --git a/pop-shell.install b/pop-shell.install
index 28fc0eb9cc8e..08a4a6a23f6c 100755
--- a/pop-shell.install
+++ b/pop-shell.install
@@ -1,7 +1,8 @@
post_install() {
echo "POP-shell configuration"
- cd /usr/share/gnome-shell/extensions/pop-shell@system76.com/scripts
- ./configure.sh
+ cd $(mktemp -d)
+ touch .confirm_shortcut_change
+ /usr/share/gnome-shell/extensions/pop-shell@system76.com/scripts/configure.sh
}
post_upgrade() {