summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2019-01-28 20:18:41 +0330
committerMohammadreza Abdollahzadeh2019-01-28 20:18:41 +0330
commite83dc885530ca9fd0fcfe0a16f8a040877ae4c8f (patch)
treef65e5f367f863b2dc3d40272c39474f0d99fd27b
downloadaur-e83dc885530ca9fd0fcfe0a16f8a040877ae4c8f.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
-rw-r--r--gnome-shell-extension.install13
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..448eb4ab83e4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = gnome-shell-extension-proxy-switcher-git
+ pkgdesc = Extension for GNOME shell to switch between the system proxy settings.
+ pkgver = 1.2.r6.g549d1aa
+ pkgrel = 1
+ url = https://github.com/tomflannaghan/proxy-switcher
+ install = gnome-shell-extension.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = python
+ depends = gnome-shell>=3.18
+ provides = gnome-shell-extension-proxy-switcher
+ conflicts = gnome-shell-extension-proxy-switcher
+ source = git+https://github.com/tomflannaghan/proxy-switcher.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-proxy-switcher-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5902a41a71e5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Mohammadreza Abdollahzadeh < morealaz at gmail dot com >
+
+pkgname=gnome-shell-extension-proxy-switcher-git
+pkgver=1.2.r6.g549d1aa
+pkgrel=1
+pkgdesc='Extension for GNOME shell to switch between the system proxy settings.'
+arch=(any)
+_githubname=proxy-switcher
+_githubowner=tomflannaghan
+url="https://github.com/${_githubowner}/${_githubname}"
+license=(GPL2)
+depends=('gnome-shell>=3.18')
+makedepends=('git' 'python')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install='gnome-shell-extension.install'
+source=("git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_githubname}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${srcdir}/${_githubname}"
+ sed -i 's|INSTALL_LOC=.*|INSTALL_LOC=$(DESTDIR)/usr/share/gnome-shell/extensions|g' \
+ Makefile
+}
+build() {
+ cd "${srcdir}/${_githubname}"
+ make build
+}
+
+package() {
+ cd "${srcdir}/${_githubname}"
+ install -d "$pkgdir/usr/share/gnome-shell/extensions"
+ make DESTDIR="$pkgdir" install
+}
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension.install b/gnome-shell-extension.install
new file mode 100644
index 000000000000..484bc1b03f77
--- /dev/null
+++ b/gnome-shell-extension.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo "==> ****************************************************"
+ echo "==> Don't forget to Restart GNOME Shell ([Alt]+[F2], r)."
+ echo "==> ****************************************************"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}