summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmin Vakil2019-10-15 17:25:58 +0330
committerAmin Vakil2019-10-15 17:25:58 +0330
commitf287af31f8e7c6b080588187f5bd4a889de220cd (patch)
treee44b6800be568cb5a57ff6f62b09de4a4c9a9d35
downloadaur-f287af31f8e7c6b080588187f5bd4a889de220cd.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..be8e46ec66a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-public-ip-git
+ pkgdesc = Tiny extension, which show public IP and nothing more.
+ pkgver = r43.1dd3422
+ pkgrel = 1
+ url = https://github.com/rostegg/public-ip-gnome-extension
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-public-ip
+ conflicts = gnome-shell-extension-public-ip
+ source = git+https://github.com/rostegg/public-ip-gnome-extension.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-public-ip-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfd3fff9b938
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Amin Vakil <info at aminvakil dot com>
+# Contributor: Rostyslav Nikolaienko <rostik.nikolaenko at gmail dot com>
+
+_srcname=public-ip-gnome-extension
+pkgname=gnome-shell-extension-public-ip-git
+pkgver=r43.1dd3422
+pkgrel=1
+pkgdesc="Tiny extension, which show public IP and nothing more."
+arch=('any')
+url="https://github.com/rostegg/public-ip-gnome-extension"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+conflicts=('gnome-shell-extension-public-ip')
+provides=('gnome-shell-extension-public-ip')
+source=("git+https://github.com/rostegg/${_srcname}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_srcname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${_srcname}"
+ local uuid=$(grep -Po '(?<="uuid": ")[^"]*' $srcdir/${_srcname}/metadata.json)
+ local destdir="$pkgdir/usr/share/gnome-shell/extensions/$uuid"
+ install -dm755 "$destdir"
+ cp -r $srcdir/${_srcname}/* "$destdir"
+}