summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexey Makhmutov2025-01-08 14:55:54 +0300
committerAlexey Makhmutov2025-01-08 14:55:54 +0300
commit93ea65bfcb75720505c260dbab0118abc5e0f2bf (patch)
tree3bf19ff4e2a11b779107566f83f237a5d8e6de13
downloadaur-gnome-shell-extension-quick-lang-switch.tar.gz
Initial release (v12, GNOME 45-47)
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore8
-rw-r--r--LICENSE9
-rw-r--r--PKGBUILD22
4 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87479759a17b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-quick-lang-switch
+ pkgdesc = Quickly switch keyboard language layout without showing the switcher popup.
+ pkgver = 12
+ pkgrel = 1
+ url = https://github.com/ankostis/gnome-shell-quick-lang-switch
+ arch = any
+ groups = gnome-shell-extensions
+ license = AGPL-3.0-or-later
+ depends = gnome-shell>=1:45
+ options = !strip
+ options = !debug
+ source = src-gnome-shell-extension-quick-lang-switch-12.tar.gz::https://github.com/ankostis/gnome-shell-quick-lang-switch/archive/refs/tags/v12.tar.gz
+ b2sums = 3b57f1e8bb1211b6b0cc970f5451595d6696135d82883dbc88b1755690c1e3a2e2494985392fce6c2e7f1b07288e14cf7f25f2c7556adb240bfc7f02b0635102
+
+pkgname = gnome-shell-extension-quick-lang-switch
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8c23fef1e88e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!.SRCINFO
+!PKGBUILD
+!LICENSE
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..733e88560b9d
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,9 @@
+Binary files, as well as any files describing changes ("patches") to the software that is being built are excluded from this license. They are provided under the license terms of the software they describe changes for.
+
+Any files containing a license notice are excluded from this license. They are provided under the license terms defined in their respective notices.
+
+Copyright 2024 Arch Linux Contributors
+
+Permission to use, copy, modify, and/or distribute this software for any purpose with or without fee is hereby granted.
+
+THE SOFTWARE IS PROVIDED “AS IS” AND THE AUTHOR DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a9113217c90c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Alexey Makhmutov <makhmutov at gmail dot com>
+pkgname=gnome-shell-extension-quick-lang-switch
+pkgver=12
+pkgrel=1
+pkgdesc="Quickly switch keyboard language layout without showing the switcher popup."
+arch=("any")
+url="https://github.com/ankostis/gnome-shell-quick-lang-switch"
+license=("AGPL-3.0-or-later")
+groups=("gnome-shell-extensions")
+depends=("gnome-shell>=1:45")
+options=("!strip" "!debug")
+_commit=af1aa83dddece116eae8a382459b16016ad9b55c
+source=("src-$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+b2sums=("3b57f1e8bb1211b6b0cc970f5451595d6696135d82883dbc88b1755690c1e3a2e2494985392fce6c2e7f1b07288e14cf7f25f2c7556adb240bfc7f02b0635102")
+
+_uuid="quick-lang-switch@ankostis.gmail.com"
+
+package() {
+ cd gnome-shell-quick-lang-switch-$pkgver
+
+ install -D extension.js metadata.json -t "$pkgdir/usr/share/gnome-shell/extensions/${_uuid}"
+}