summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMohammadreza Abdollahzadeh2017-01-24 21:21:39 +0330
committerMohammadreza Abdollahzadeh2017-01-24 21:21:39 +0330
commit9cf91bdb9ede3548865b444377d40478b298ea4c (patch)
treebc759f532e151f8df442014dfae6d31fc2ddf5ec
downloadaur-9cf91bdb9ede3548865b444377d40478b298ea4c.tar.gz
initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
-rw-r--r--gnome-shell.install19
3 files changed, 73 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..49701c2f5005
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+# Generated by mksrcinfo v8
+# Tue Jan 24 17:51:02 UTC 2017
+pkgbase = gnome-shell-extension-radio-git
+ pkgdesc = Gnome shell extension for listening to internet radio streams.
+ pkgver = 1.4.r25.gd6d6eb3
+ pkgrel = 1
+ url = https://github.com/hslbck/gnome-shell-extension-radio
+ install = gnome-shell.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gnome-shell>=3.18
+ depends = gst-plugins-bad
+ depends = gst-plugins-bad
+ depends = gst-plugins-bad
+ depends = gst-plugins-bad
+ provides = gnome-shell-extension-radio
+ conflicts = gnome-shell-extension-radio
+ source = gnome-shell-extension-radio::git+https://github.com/hslbck/gnome-shell-extension-radio.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-radio-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21296577595f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Mohammadreza Abdollahzadeh <morealaz at gmail dot com>
+
+pkgname=gnome-shell-extension-radio-git
+pkgver=1.4.r25.gd6d6eb3
+pkgrel=1
+pkgdesc="Gnome shell extension for listening to internet radio streams."
+arch=(any)
+url="https://github.com/hslbck/gnome-shell-extension-radio"
+license=('GPL')
+depends=('gnome-shell>=3.18' 'gst-plugins-bad' 'gst-plugins-bad' 'gst-plugins-bad' 'gst-plugins-bad')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=gnome-shell.install
+source=("${pkgname%-git}::git+https://github.com/hslbck/gnome-shell-extension-radio.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/gnome-shell.install b/gnome-shell.install
new file mode 100644
index 000000000000..fd1ccf6c4d79
--- /dev/null
+++ b/gnome-shell.install
@@ -0,0 +1,19 @@
+post_install() {
+ instruct
+ echo "and enable the extension with gnome-tweak-tool."
+}
+
+post_upgrade() {
+ instruct
+ echo "for the changes to have an effect."
+}
+
+post_remove() {
+ instruct
+}
+
+instruct() {
+ echo "Don't forget to restart GNOME Shell ([Alt]+[F2], r)"
+}
+
+# vim: ts=2 sw=2 et: