summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Andersson2016-10-18 23:24:04 +0200
committerMaxim Andersson2016-10-18 23:24:04 +0200
commit1071af17bd4e7e1e45d3d6451f1287a0ac74dcd0 (patch)
tree7e4ccf8e75b61dabc11a6424797b3f96b143da4d
downloadaur-1071af17bd4e7e1e45d3d6451f1287a0ac74dcd0.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
-rw-r--r--gnome-shell-extension-remove-dropdown-arrows.install6
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d647e226efc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Tue Oct 18 21:19:33 UTC 2016
+pkgbase = gnome-shell-extension-remove-dropdown-arrows
+ pkgdesc = Removes the dropdown arrows from the AppMenu and SystemMenu
+ pkgver = 7
+ pkgrel = 1
+ url = https://github.com/mpdeimos/gnome-shell-remove-dropdown-arrows
+ install = gnome-shell-extension-remove-dropdown-arrows.install
+ arch = any
+ license = GPL3
+ depends = gnome-shell
+ source = https://github.com/mpdeimos/gnome-shell-remove-dropdown-arrows/archive/version/7.tar.gz
+ sha256sums = 196cc6d23b54a68550ed752a9f48b4898457d941ce69de7973fe7fe5386ca22d
+
+pkgname = gnome-shell-extension-remove-dropdown-arrows
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..61fd7229ed13
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Maxim Andersson <thesilentboatman@gmail.com>
+
+pkgname=gnome-shell-extension-remove-dropdown-arrows
+pkgver=7
+pkgrel=1
+pkgdesc="Removes the dropdown arrows from the AppMenu and SystemMenu"
+arch=('any')
+url="https://github.com/mpdeimos/gnome-shell-remove-dropdown-arrows"
+license=('GPL3')
+depends=('gnome-shell')
+install=${pkgname}.install
+source=("https://github.com/mpdeimos/gnome-shell-remove-dropdown-arrows/archive/version/${pkgver}.tar.gz")
+sha256sums=('196cc6d23b54a68550ed752a9f48b4898457d941ce69de7973fe7fe5386ca22d')
+
+package() {
+ _uuid='remove-dropdown-arrows@mpdeimos.com'
+
+ cd "${srcdir}/gnome-shell-remove-dropdown-arrows-version-${pkgver}"
+
+ install -Dm644 extension.js -t "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ install -Dm644 metadata.json -t "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension-remove-dropdown-arrows.install b/gnome-shell-extension-remove-dropdown-arrows.install
new file mode 100644
index 000000000000..92d1396b2b04
--- /dev/null
+++ b/gnome-shell-extension-remove-dropdown-arrows.install
@@ -0,0 +1,6 @@
+post_install() {
+ echo ''
+ echo '==> Enable it with the gnome-tweak-tool'
+ echo '==> or run "gnome-shell-extension-tool -e remove-dropdown-arrows@mpdeimos.com"'
+ echo ''
+}