summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXZS2016-11-01 13:58:09 +0100
committerXZS2016-11-01 13:58:09 +0100
commit5c0ed052640dd32a1d00253bbed75e6975a9ff62 (patch)
treee88dc8820bfb08de019d9815abdc5f361cf99655
parent6d0d9266b955eea4789740dac326cae565c46f58 (diff)
downloadaur-5c0ed052640dd32a1d00253bbed75e6975a9ff62.tar.gz
choose newest extension source
Some extensions authors introduce build steps required before installing. Their execution normally produces a completed variant of the extension code in a subdirectory, difficult to tell apart from the original source. The find condition introduced herein proves the process against such cases to come. It always chooses the files created last, ensuring that a build which occurred after mere unpacking will always take precedence.
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90eee5eb2d04..c1bc0dc43ef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -34,7 +34,8 @@ package() {
}
package_01_locate() {
msg2 'Locating extension...'
- cd "$(find -name 'metadata.json' -execdir test -e extension.js \; -printf %h -quit)"
+ cd "$(find -name 'metadata.json' -execdir test -e extension.js \; \
+ -printf '%C@ %h\n' | sort -nr | sed 's/^.* //;q' )"
extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
destdir="$pkgdir/usr/share/gnome-shell/extensions/$extname"
}