summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZiarnova2021-01-17 13:05:13 +0300
committerZiarnova2021-01-17 13:05:13 +0300
commitbe9d4e62c0534219e73b8907752ef50bfe429917 (patch)
treebc671984a460fb51f8529b559831ae3e8c809fea
downloadaur-be9d4e62c0534219e73b8907752ef50bfe429917.tar.gz
initital commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 30 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..63d8deb71ab2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-resource-monitor
+ pkgdesc = Monitor the use of system resources like cpu, ram, disk, network and display them in gnome shell top bar
+ pkgver = 10
+ pkgrel = 1
+ url = https://github.com/0ry0n/Resource_Monitor/
+ arch = any
+ license = GPL
+ depends = gnome-shell
+ source = gnome-shell-extension-resource-monitor-10.tar.gz::https://github.com/0ry0n/Resource_Monitor//archive/10.tar.gz
+ sha512sums = 62562bdceeb2e69336d705cdbdbc91ed0181ceb35fd042b29fb933dcc4cfb43cfc518f3995a361359ef9b4e77f70bcc72f3503c5ebf7ce2c063642aa23889f0e
+
+pkgname = gnome-shell-extension-resource-monitor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..190e52dfb4b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Ziarnova
+
+pkgname=gnome-shell-extension-resource-monitor
+pkgver=10
+pkgrel=1
+pkgdesc="Monitor the use of system resources like cpu, ram, disk, network and display them in gnome shell top bar"
+arch=("any")
+url="https://github.com/0ry0n/Resource_Monitor/"
+license=("GPL")
+depends=("gnome-shell")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/10.tar.gz")
+sha512sums=("62562bdceeb2e69336d705cdbdbc91ed0181ceb35fd042b29fb933dcc4cfb43cfc518f3995a361359ef9b4e77f70bcc72f3503c5ebf7ce2c063642aa23889f0e")
+
+package() {
+install -d "$pkgdir/usr/share/gnome-shell/extensions"
+cp -a "$srcdir/Resource_Monitor-$pkgver/." "$pkgdir/usr/share/gnome-shell/extensions/Resource_Monitor@Ory0n"
+}