summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2022-08-04 11:43:23 -0600
committerMark Wagie2022-08-04 11:43:23 -0600
commita112fd85586c60bb5bc6bdeff3eb0c7be7112daf (patch)
treef890e55e60059c5dd7d2bead4d1992705c1d8878
parente01c3070b0b7ce6b21b712b81f0858d4287203cb (diff)
downloadaur-a112fd85586c60bb5bc6bdeff3eb0c7be7112daf.tar.gz
add missing files, add missing build dep, PKGBUILD improvements
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD56
3 files changed, 41 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c701f882a0d6..e1fb320982c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = gnome-shell-extension-rounded-window-corners-git
- pkgdesc = A gnome-shell extensions that try to add rounded corners for all windows
- pkgver = r62.59b903b
+ pkgdesc = A GNOME Shell extension that adds rounded corners for all windows
+ pkgver = 4.r10.g508abee
pkgrel = 1
url = https://github.com/yilozt/rounded-window-corners
arch = any
license = GPL3
makedepends = git
+ makedepends = gobject-introspection
makedepends = yarn
- makedepends = zip
depends = gnome-shell
provides = gnome-shell-extension-rounded-window-corners
conflicts = gnome-shell-extension-rounded-window-corners
source = git+https://github.com/yilozt/rounded-window-corners.git
- b2sums = SKIP
+ sha256sums = SKIP
pkgname = gnome-shell-extension-rounded-window-corners-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index f1777d0a3a44..9036311c221a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,52 @@
# Maintainer: Igor Dyatlov <dyatlov.igor@protonmail.com>
-
+# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=gnome-shell-extension-rounded-window-corners-git
-_pkgname=rounded-window-corners
-pkgver=r62.59b903b
+pkgver=4.r10.g508abee
pkgrel=1
-pkgdesc="A gnome-shell extensions that try to add rounded corners for all windows"
+pkgdesc="A GNOME Shell extension that adds rounded corners for all windows"
arch=('any')
url="https://github.com/yilozt/rounded-window-corners"
license=('GPL3')
depends=('gnome-shell')
-makedepends=('git' 'yarn' 'zip')
+makedepends=('git' 'gobject-introspection' 'yarn')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=(git+$url.git)
-b2sums=('SKIP')
+source=('git+https://github.com/yilozt/rounded-window-corners.git')
+sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname%-git}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "$srcdir/rounded-window-corners"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${_pkgname%-git}"
-
+ cd "$srcdir/rounded-window-corners"
+ yarn config set cache-folder "$srcdir/yarn-cache"
yarn install
yarn build
+
+ pushd _build
+ gnome-extensions pack \
+ --extra-source=dbus \
+ --extra-source=effect \
+ --extra-source=manager \
+ --extra-source=preferences \
+ --extra-source=utils \
+ --extra-source=app.js \
+ --extra-source=stylesheet.css \
+ --extra-source=stylesheet-prefs.css \
+ --force
+ popd
}
package() {
- cd "${_pkgname%-git}"/_build
- glib-compile-schemas schemas
- gnome-extensions pack \
- --force \
- --extra-source="dbus" \
- --extra-source="effect" \
- --extra-source="manager" \
- --extra-source="preferences" \
- --extra-source="schemas" \
- --extra-source="utils"
+ cd "$srcdir/rounded-window-corners"
+ local uuid=$(grep -Po '(?<="uuid": ")[^"]*' _build/metadata.json)
- local uuid=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
install -d "$pkgdir/usr/share/gnome-shell/extensions/${uuid}"
- bsdtar -xvf ${uuid}.shell-extension.zip -C "$pkgdir/usr/share/gnome-shell/extensions/${uuid}"
+ bsdtar -xvf "_build/${uuid}.shell-extension.zip" -C "$pkgdir/usr/share/gnome-shell/extensions/${uuid}/"
+
+ install -Dm644 _build/schemas/org.gnome.shell.extensions.rounded-window-corners.gschema.xml -t \
+ "$pkgdir/usr/share/glib-2.0/schemas/"
+ rm -rf "$pkgdir/usr/share/gnome-shell/extensions/${uuid}/schemas/"
}