summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIgor Dyatlov2021-08-30 18:13:08 +0300
committerIgor Dyatlov2021-08-30 18:13:08 +0300
commitb13c05057f8b028c7b642c435e73056f40731fe6 (patch)
tree021671cb5dcbcd0364084c9d2cfe2aa72a808e84
downloadaur-b13c05057f8b028c7b642c435e73056f40731fe6.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e2ca7650c280
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-screenshotlocations
+ pkgdesc = A GNOME extension for changing the screenshot output directory
+ pkgver = 8
+ pkgrel = 1
+ url = https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension
+ arch = any
+ license = GPL2
+ makedepends = meson
+ makedepends = eslint
+ depends = gnome-shell
+ source = https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension/archive/8.tar.gz
+ sha256sums = 0a2de2ae960712c4edbf2f303531d828be119a4b9f47ad5292c7f8e15cdeff67
+
+pkgname = gnome-shell-extension-screenshotlocations
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b1fc8b705ca8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Your Name <youremail@domain.com>
+
+pkgname=gnome-shell-extension-screenshotlocations
+_pkgname=gnome-shell-screenshotlocations-extension
+pkgver=8
+pkgrel=1
+pkgdesc="A GNOME extension for changing the screenshot output directory"
+arch=('any')
+url="https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension"
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('meson' 'eslint')
+source=(https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension/archive/8.tar.gz)
+sha256sums=('0a2de2ae960712c4edbf2f303531d828be119a4b9f47ad5292c7f8e15cdeff67')
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ arch-meson --buildtype=plain build
+ ninja -C build
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ DESTDIR="$pkgdir" ninja -C build install
+}