summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorananaso2021-04-18 17:51:05 -0700
committerananaso2021-04-18 17:51:05 -0700
commitb66342c32cd92f312f6d23a5a4f21bf90d4ce40d (patch)
tree4d7804763854cbe4f66cf54524f78c9300bac7af
parent76eb65e4d3299918915da69eebdb376478dc83fd (diff)
downloadaur-b66342c32cd92f312f6d23a5a4f21bf90d4ce40d.tar.gz
updated to new URL, fixed pkgdesc
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD41
2 files changed, 28 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c8c29b7ab197..3bf77bb74270 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
-pkgbase = gnome-shell-extension-screenshotlocations-git
- pkgdesc = Gnome-shell extension disabling hotcorners
- pkgver = 25.2948bc8
+pkgbase = gnome-shell-screenshotlocations-extension-git
+ pkgdesc = A GNOME extension for changing the screenshot output directory
+ pkgver = r31.dfdcf12
pkgrel = 1
- url = https://github.com/TimurKiyivinski/gnome-shell-screenshotlocations-extension
+ url = https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension
arch = any
- license = GPLv2
+ license = GPL2
makedepends = git
+ makedepends = meson
+ makedepends = eslint
depends = gnome-shell
- source = git://github.com/TimurKiyivinski/gnome-shell-screenshotlocations-extension
+ source = git+https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension.git
sha256sums = SKIP
-pkgname = gnome-shell-extension-screenshotlocations-git
+pkgname = gnome-shell-screenshotlocations-extension-git
diff --git a/PKGBUILD b/PKGBUILD
index 42cd737abb80..eb762d6c4c4d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,30 @@
-# Maintainer: 4679kun <4679kun@outlook.com>
+# Maintainer: ananaso <adavidson+aur@protonmail.ch>
+# Contributor: 4679kun <4679kun@outlook.com>
-pkgname=gnome-shell-extension-screenshotlocations-git
-_gitname=gnome-shell-screenshotlocations-extension
-pkgver=25.2948bc8
+pkgname=gnome-shell-screenshotlocations-extension-git
+pkgver=r31.dfdcf12
pkgrel=1
-pkgdesc="Gnome-shell extension disabling hotcorners"
+pkgdesc="A GNOME extension for changing the screenshot output directory"
arch=('any')
-url="https://github.com/TimurKiyivinski/gnome-shell-screenshotlocations-extension"
-license=('GPLv2')
+url="https://codeberg.org/kiyui/gnome-shell-screenshotlocations-extension"
+license=('GPL2')
depends=('gnome-shell')
-makedepends=('git')
-source=('git://github.com/TimurKiyivinski/gnome-shell-screenshotlocations-extension')
+makedepends=('git' 'meson' 'eslint')
+source=('git+'${url}'.git')
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${_gitname}"
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ arch-meson --buildtype=plain build
+ ninja -C build
}
package() {
- _uuid='screenshotlocations.timur@linux.com'
-
- cd "$_gitname/$_uuid"
- install -Dm644 "metadata.json" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
- install -m644 "extension.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
- install -Dm644 "keybinder.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/keybinder.js"
- install -m644 "prefs.js" \
- "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/prefs.js"
+ cd "$srcdir/${pkgname%-git}"
+ DESTDIR="$pkgdir" ninja -C build install
}