summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiawei Zhou2018-12-22 02:14:26 +0800
committerJiawei Zhou2018-12-22 02:14:26 +0800
commitd156bc44ab9a0922c14fd0a89dbcca637b8fc063 (patch)
tree9bd30e475886fa9c7c4ddfb6a76a55eb1706ab69
downloadaur-d156bc44ab9a0922c14fd0a89dbcca637b8fc063.tar.gz
initial
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD33
-rw-r--r--notice.install15
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c8c29b7ab197
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-screenshotlocations-git
+ pkgdesc = Gnome-shell extension disabling hotcorners
+ pkgver = 25.2948bc8
+ pkgrel = 1
+ url = https://github.com/TimurKiyivinski/gnome-shell-screenshotlocations-extension
+ arch = any
+ license = GPLv2
+ makedepends = git
+ depends = gnome-shell
+ source = git://github.com/TimurKiyivinski/gnome-shell-screenshotlocations-extension
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-screenshotlocations-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42cd737abb80
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: 4679kun <4679kun@outlook.com>
+
+pkgname=gnome-shell-extension-screenshotlocations-git
+_gitname=gnome-shell-screenshotlocations-extension
+pkgver=25.2948bc8
+pkgrel=1
+pkgdesc="Gnome-shell extension disabling hotcorners"
+arch=('any')
+url="https://github.com/TimurKiyivinski/gnome-shell-screenshotlocations-extension"
+license=('GPLv2')
+depends=('gnome-shell')
+makedepends=('git')
+source=('git://github.com/TimurKiyivinski/gnome-shell-screenshotlocations-extension')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ _uuid='screenshotlocations.timur@linux.com'
+
+ cd "$_gitname/$_uuid"
+ install -Dm644 "metadata.json" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
+ install -m644 "extension.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
+ install -Dm644 "keybinder.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/keybinder.js"
+ install -m644 "prefs.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/prefs.js"
+}
diff --git a/notice.install b/notice.install
new file mode 100644
index 000000000000..bac60d6e7b45
--- /dev/null
+++ b/notice.install
@@ -0,0 +1,15 @@
+post_install() {
+ instruct
+ echo "and enable the extension with gnome-tweak-tool."
+}
+
+post_upgrade() {
+ instruct
+ echo "for the changes to have an effect."
+}
+
+instruct() {
+ echo "Don't forget to restart GNOME Shell ([Alt]+[F2], r)"
+}
+
+# vim: ts=2 sw=2 et: