summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorliolok2020-10-08 22:21:26 +0800
committerliolok2020-10-08 22:21:26 +0800
commit2d8d5e794f697b0328cdcd78498ec5615db333ae (patch)
tree58f73c1e2bf8f12b6b8312128b960fb940e3eaaa
downloadaur-2d8d5e794f697b0328cdcd78498ec5615db333ae.tar.gz
initialize with v22
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD28
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1a631219256
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-scroll-workspaces
+ pkgdesc = Switch workspaces by scrolling in the top panel
+ pkgver = 22
+ pkgrel = 1
+ url = https://extensions.gnome.org/extension/701/scroll-workspaces/
+ arch = any
+ license = GPL2
+ depends = gnome-shell>=3.36
+ source = gnome-shell-extension-scroll-workspaces.zip::https://extensions.gnome.org/download-extension/scroll-workspaces@gfxmonk.net.shell-extension.zip?version_tag=16519
+ sha256sums = 0acbcc0a0ea10d221e15a45ea861994ad290fee0df237531fe16ac15b4842268
+
+pkgname = gnome-shell-extension-scroll-workspaces
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ec36803d28bd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: liolok <aur@liolok.com>
+
+# https://extensions.gnome.org/extension-info/?pk=701&shell_version=3.36
+_gnome_site='https://extensions.gnome.org'
+_name='scroll-workspaces'
+_uuid='scroll-workspaces@gfxmonk.net'
+_pk=701
+_gnome_shell_version=3.36
+_version=22
+_version_tag=16519
+
+pkgname="gnome-shell-extension-$_name"
+pkgver=$_version
+pkgrel=1
+pkgdesc='Switch workspaces by scrolling in the top panel'
+arch=('any')
+url="$_gnome_site/extension/$_pk/$_name/"
+license=('GPL2')
+depends=("gnome-shell>=$_gnome_shell_version")
+source=("$pkgname.zip::$_gnome_site/download-extension/$_uuid.shell-extension.zip?version_tag=$_version_tag")
+sha256sums=('0acbcc0a0ea10d221e15a45ea861994ad290fee0df237531fe16ac15b4842268')
+
+package() {
+ local _destdir="$pkgdir/usr/share/gnome-shell/extensions/$_uuid"
+ install --directory "$_destdir"
+ chmod 644 ./metadata.json
+ cp --archive ./*[^*.zip] --target-directory="$_destdir"
+}