summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabien JUIF2016-02-13 14:38:58 +0100
committerFabien JUIF2016-02-13 14:38:58 +0100
commit9218891218a161ecb2727b355fd9dec1ad1bc28c (patch)
treec221ad157bab462abe7ecddb5c1d199e41336766
downloadaur-9218891218a161ecb2727b355fd9dec1ad1bc28c.tar.gz
First version. Don't work atm.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD60
-rw-r--r--gnome-shell-extension-shellshape-git.install11
-rw-r--r--makefile14
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc59457303f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Feb 13 13:34:19 UTC 2016
+pkgbase = gnome-shell-extension-shellshape-git
+ pkgdesc = Tiling window manager extension for gnome-shell.
+ pkgver = r306.839fe66
+ pkgrel = 1
+ url = http://gfxmonk.net/shellshape
+ install = gnome-shell-extension-shellshape-git.install
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = git
+ makedepends = npm
+ depends = gnome-shell
+ source = git+https://github.com/timbertson/shellshape
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-shellshape-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8805004edffe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,60 @@
+# Maintainer: Fabien JUIF <fabien.juif@gmail.com>
+application=shellshape
+pkgname=gnome-shell-extension-${application}-git
+pkgrel=1
+pkgver=r306.839fe66
+license=('GPL3')
+pkgdesc="Tiling window manager extension for gnome-shell."
+url="http://gfxmonk.net/shellshape"
+arch=('x86_64' 'i686')
+depends=('gnome-shell')
+makedepends=('git' 'npm')
+install=${pkgname}.install
+source=(
+ "git+https://github.com/timbertson/${application}"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+build() {
+ cd ${srcdir}/${application}
+ build_dir=${srcdir}/${application}/${application}
+
+ # build it
+ make
+}
+
+package() {
+ build_dir=${srcdir}/${application}/${application}
+
+ # directories architecture
+ mkdir -p ${pkgdir}/usr/share/gnome-shell/extensions/shellshape@gfxmonk.net
+ mkdir -p ${pkgdir}/usr/share/icons
+ mkdir -p ${pkgdir}/usr/share/glib-2.0/schemas
+
+ # copies
+ # - extension
+ dest_dir="${pkgdir}/usr/share/gnome-shell/extensions/shellshape@gfxmonk.net"
+ cp ${srcdir}/${application}/build/gjs/*.js ${dest_dir}/
+ cp ${build_dir}/metadata.json ${dest_dir}/
+ cp ${build_dir}/shellshape.pot ${dest_dir}/
+ cp -R ${build_dir}/lib ${dest_dir}/
+
+ # Locales
+ cp -R ${build_dir}/locale ${pkgdir}/usr/share/locale
+
+ # Glib-2.0
+ cp ${srcdir}/${application}/schemas/*.xml ${pkgdir}/usr/share/glib-2.0/schemas/
+
+ # Icons
+ cp -R ${srcdir}/${application}/icons ${pkgdir}/usr/share/icons
+
+}
+
+pkgver() {
+ cd ${application}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension-shellshape-git.install b/gnome-shell-extension-shellshape-git.install
new file mode 100644
index 000000000000..326aa98a2f02
--- /dev/null
+++ b/gnome-shell-extension-shellshape-git.install
@@ -0,0 +1,11 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
diff --git a/makefile b/makefile
new file mode 100644
index 000000000000..1dd49b2aa3d0
--- /dev/null
+++ b/makefile
@@ -0,0 +1,14 @@
+all: clean main install
+
+clean:
+ rm -Rf pkg
+ rm -Rf src
+ rm -Rf shellshape
+ rm -Rf *shellshape-git-*.pkg.tar.xz
+
+main:
+ makepkg
+ mksrcinfo
+
+install:
+ sudo pacman -U *shellshape-git-*.pkg.tar.xz