summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Andersson2017-01-14 15:51:04 +0100
committerMaxim Andersson2017-01-14 15:51:04 +0100
commit39f0191d3cc7d5e024b562e99bbd6c43c4d341f3 (patch)
tree486f2acf1ac82b6f48e7e8afca293ef8afafc3a1
downloadaur-39f0191d3cc7d5e024b562e99bbd6c43c4d341f3.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
-rw-r--r--gnome-shell-extension-shortcuts.install8
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fd59b097a3e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Jan 14 14:49:44 UTC 2017
+pkgbase = gnome-shell-extension-shortcuts
+ pkgdesc = Creates a pop-up that describes the commonly used keyboard shortcuts in GNOME Shell
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://gitlab.com/paddatrapper/shortcuts-gnome-extension
+ install = gnome-shell-extension-shortcuts.install
+ arch = any
+ license = GPL3
+ makedepends = gettext
+ depends = gnome-shell
+ options = !emptydirs
+ source = https://gitlab.com/paddatrapper/shortcuts-gnome-extension/repository/archive.tar.gz?ref=1.0.4
+ sha256sums = b815faf0bac4f24eb70bb72495abfe422af1651333e41b94d6a10fa7b9e18a8b
+
+pkgname = gnome-shell-extension-shortcuts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d30b8f31ff6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Maxim Andersson <thesilentboatman@gmail.com>
+
+pkgname=gnome-shell-extension-shortcuts
+_gitname=shortcuts-gnome-extension
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Creates a pop-up that describes the commonly used keyboard shortcuts in GNOME Shell"
+arch=('any')
+url="https://gitlab.com/paddatrapper/shortcuts-gnome-extension"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('gettext')
+options=('!emptydirs')
+install=${pkgname}.install
+source=("https://gitlab.com/paddatrapper/${_gitname}/repository/archive.tar.gz?ref=${pkgver}")
+sha256sums=('b815faf0bac4f24eb70bb72495abfe422af1651333e41b94d6a10fa7b9e18a8b')
+
+build() {
+ cd "${srcdir}/${_gitname}-${pkgver}"*
+
+ for po in locale/*/LC_MESSAGES/*.po; do
+ msgfmt -cv -o ${po%.po}.mo $po;
+ done
+}
+
+package() {
+ cd "${srcdir}/${_gitname}-${pkgver}"*
+
+ _uuid='Shortcuts@kyle.aims.ac.za'
+
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ install -d "${pkgdir}/usr/share/glib-2.0/schemas"
+
+ mv "src/schemas/org.gnome.shell.extensions.shortcuts.gschema.xml" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/"
+ cp -r src/* locale "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension-shortcuts.install b/gnome-shell-extension-shortcuts.install
new file mode 100644
index 000000000000..7d97fc5d9c12
--- /dev/null
+++ b/gnome-shell-extension-shortcuts.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ''
+ echo '==> To enable Shortcuts:'
+ echo '==> Reload Gnome Shell with Alt-F2 r (on Xorg)'
+ echo '==> Enable it with the gnome-tweak-tool'
+ echo '==> or run "gnome-shell-extension-tool -e Shortcuts@kyle.aims.ac.za"'
+ echo ''
+}