summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLinArcX2018-07-09 22:17:38 +0430
committerLinArcX2018-07-09 22:17:38 +0430
commita16ac905e6a6417abd93ace3aae316147b2bca6f (patch)
tree034889e5dd6c22b899d83b645594adc6d56df3eb
downloadaur-a16ac905e6a6417abd93ace3aae316147b2bca6f.tar.gz
Init AUR Repo
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD31
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16543f1fb531
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gnome-shell-extension-show-desktop-button
+ pkgdesc = Add Show Desktop Button to Gnome Panel.
+ pkgver = r4.8cf4f41
+ pkgrel = 1
+ url = https://github.com/amivaleo/Show-Desktop-Button
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell>=3.24
+ provides = gnome-shell-extension-show-desktop-button
+ conflicts = gnome-shell-extension-show-desktop-button
+ replaces = gnome-shell-extension-show-desktop-button
+ source = gnome-shell-extension-show-desktop-button::git+https://github.com/amivaleo/Show-Desktop-Button
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-show-desktop-button
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8783b88cf37a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: LinArcx <linarcx@gmail.com>
+
+pkgname=gnome-shell-extension-show-desktop-button
+pkgver=r4.8cf4f41
+pkgrel=1
+pkgdesc="Add Show Desktop Button to Gnome Panel."
+arch=(any)
+url="https://github.com/amivaleo/Show-Desktop-Button"
+license=(GPL3)
+depends=('gnome-shell>=3.24')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=("${pkgname%-git}")
+makedepends=(git)
+# install='gnome-shell-extension.install'
+source=("${pkgname%-git}"::"git+https://github.com/amivaleo/Show-Desktop-Button")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+package() {
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/show-desktop-button@amivaleo"
+ cp -a $srcdir/${pkgname%-git}/* "$pkgdir/usr/share/gnome-shell/extensions/show-desktop-button@amivaleo"
+ rm -rf $pkgdir/usr/share/gnome-shell/extensions/show-desktop-button@amivaleo/.git
+} \ No newline at end of file