summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKalle Lindqvist2018-06-05 10:32:55 +0200
committerKalle Lindqvist2018-06-05 10:32:55 +0200
commit40b35e87cc6170e0179b71c4b9d0eea49a15661f (patch)
tree7d08b8b2bd928e5b22fb3b07a66d98ddccc8341b
downloadaur-40b35e87cc6170e0179b71c4b9d0eea49a15661f.tar.gz
V.16
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD21
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fc2fadc5d9d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-sound-output-device-chooser
+ pkgdesc = Sound Input & Output Device Chooser.
+ pkgver = 16
+ pkgrel = 1
+ url = https://github.com/kgshank/gse-sound-output-device-chooser
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gnome-shell
+ source = git://github.com/kgshank/gse-sound-output-device-chooser.git#commit=0bfc897445b22aff19bf8162b1688de071e15e7f
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-sound-output-device-chooser
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eda10570a432
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Kalle Lindqvist <kalle.lindqvist@mykolab.com>
+pkgname=gnome-shell-extension-sound-output-device-chooser
+_gitname="gse-sound-output-device-chooser"
+pkgver=16
+pkgrel=1
+pkgdesc="Sound Input & Output Device Chooser."
+arch=('any')
+url="https://github.com/kgshank/gse-sound-output-device-chooser"
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('git')
+source=("git://github.com/kgshank/${_gitname}.git#commit=0bfc897445b22aff19bf8162b1688de071e15e7f")
+md5sums=("SKIP")
+
+package() {
+ _uuid="sound-output-device-chooser@kgshank.net"
+
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ cp -r "${srcdir}/${_gitname}/${_uuid}/"* \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+}