summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Gierer2019-04-24 17:24:48 +0200
committerJonas Gierer2019-04-24 17:24:48 +0200
commite6652faffcaa0ff8e25755a2dded9ec4a70bb6d9 (patch)
treecae8f38c2ce63c94579f06f95d2d1c8e39649c75
downloadaur-gnome-shell-extension-stealmyfocus.tar.gz
v2018_05_17-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD17
2 files changed, 29 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e87f2f98020a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = gnome-shell-extension-stealmyfocus
+ pkgdesc = Removes the annoying 'Window is ready' notification and focus window immediately.
+ pkgver = 2018_05_17
+ pkgrel = 1
+ url = https://github.com/tak0kada/gnome-shell-extension-stealmyfocus
+ arch = any
+ conflicts = gnome-shell-extension-stealmyfocus-git
+ source = https://github.com/tak0kada/gnome-shell-extension-stealmyfocus/archive/2d163feaa0ab5efabba3a3daa14243216c1775a8.tar.gz
+ sha256sums = 47eb7ada104b760e8240e17ad6590b4ee3dd963d5f382e5f263b3b373bfa9d9a
+
+pkgname = gnome-shell-extension-stealmyfocus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..060eac8c5ac0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Jonas Gierer <jgierer12@gmail.com>
+
+pkgname=gnome-shell-extension-stealmyfocus
+pkgver=2018_05_17
+_pkgver_sha=2d163feaa0ab5efabba3a3daa14243216c1775a8
+pkgrel=1
+pkgdesc="Removes the annoying 'Window is ready' notification and focus window immediately."
+_uuid="steal-my-focus@kagesenshi.org"
+arch=(any)
+url="https://github.com/tak0kada/gnome-shell-extension-stealmyfocus"
+conflicts=(gnome-shell-extension-stealmyfocus-git)
+source=("https://github.com/tak0kada/gnome-shell-extension-stealmyfocus/archive/${_pkgver_sha}.tar.gz")
+sha256sums=('47eb7ada104b760e8240e17ad6590b4ee3dd963d5f382e5f263b3b373bfa9d9a')
+
+package() {
+ install -m644 $pkgname-$_pkgver_sha/*.{js,json} -Dt $pkgdir/usr/share/gnome-shell/extensions/$_uuid
+}