summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorijan Hamzic2018-05-02 15:32:30 +0200
committerFlorijan Hamzic2018-05-02 15:32:30 +0200
commitf209b58ed76b17a530dea879ac35370be872f474 (patch)
treeb34ab49e65ba162c756705b0ff4235842889ac67
downloadaur-gnome-shell-extension-stocks.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
-rw-r--r--gnome-shell.install19
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a2f217bdae2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Wed May 2 13:32:08 UTC 2018
+pkgbase = gnome-shell-extension-stocks
+ pkgdesc = Gnome shell extension for displaying stock quotes in panel
+ pkgver = 3
+ pkgrel = 1
+ url = https://github.com/cinatic/stocks-extension
+ install = gnome-shell.install
+ arch = any
+ license = GPL
+ depends = gnome-shell>=3.18
+ source = https://github.com/cinatic/stocks-extension/archive/v3_1.tar.gz
+ sha256sums = 7d9a112827ccd187fdd12b0282518f5d2f2bd82bc0a60a84b51ee741b05cbe53
+
+pkgname = gnome-shell-extension-stocks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..209480d97879
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Florijan Hamzic <fh[at]infinicode.de>
+
+pkgname=gnome-shell-extension-stocks
+pkgver=3
+pkgrel=1
+pkgdesc="Gnome shell extension for displaying stock quotes in panel"
+arch=(any)
+url="https://github.com/cinatic/stocks-extension"
+license=('GPL')
+depends=('gnome-shell>=3.18')
+install=gnome-shell.install
+source=("https://github.com/cinatic/stocks-extension/archive/v${pkgver}_${pkgrel}.tar.gz")
+sha256sums=('7d9a112827ccd187fdd12b0282518f5d2f2bd82bc0a60a84b51ee741b05cbe53')
+
+build() {
+ cd "$srcdir/stocks-extension-${pkgver}_${pkgrel}"
+ make
+}
+
+package() {
+ cd "$srcdir/stocks-extension-${pkgver}_${pkgrel}"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/gnome-shell.install b/gnome-shell.install
new file mode 100644
index 000000000000..fd1ccf6c4d79
--- /dev/null
+++ b/gnome-shell.install
@@ -0,0 +1,19 @@
+post_install() {
+ instruct
+ echo "and enable the extension with gnome-tweak-tool."
+}
+
+post_upgrade() {
+ instruct
+ echo "for the changes to have an effect."
+}
+
+post_remove() {
+ instruct
+}
+
+instruct() {
+ echo "Don't forget to restart GNOME Shell ([Alt]+[F2], r)"
+}
+
+# vim: ts=2 sw=2 et: