summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2015-06-18 17:10:25 +0200
committerPieter Goetschalckx2015-06-18 17:10:25 +0200
commit2085da1acfd4863d3f45814e09ac0d5ff7820e50 (patch)
tree2bf014cbdb01489db2c8065df3cc4af44eeb6392
downloadaur-2085da1acfd4863d3f45814e09ac0d5ff7820e50.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--gnome-shell-extension-suspend-button.install11
3 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..adb75773331e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-suspend-button-git
+ pkgdesc = Allows to modify the suspend/shutdown button in the status menu.
+ pkgver = r15.9321c11
+ pkgrel = 1
+ url = https://github.com/laserb/gnome-shell-extension-suspend-button
+ install = gnome-shell-extension-suspend-button.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = gnome-shell
+ source = gnome-shell-extension-suspend-button-git::git+https://github.com/laserb/gnome-shell-extension-suspend-button
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-suspend-button-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10d9197bcc3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter at gmail dot com>
+
+pkgname=gnome-shell-extension-suspend-button-git
+pkgver=r15.9321c11
+pkgrel=1
+pkgdesc="Allows to modify the suspend/shutdown button in the status menu."
+arch=('i686' 'x86_64')
+url="https://github.com/laserb/gnome-shell-extension-suspend-button"
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('git')
+install=gnome-shell-extension-suspend-button.install
+source=("$pkgname::git+https://github.com/laserb/gnome-shell-extension-suspend-button")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ _uuid='suspend-button@laserb'
+
+ install -Dm644 "metadata.json" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/metadata.json"
+ install -m644 "extension.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/extension.js"
+ install -m644 "prefs.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/prefs.js"
+ install -m644 "lib.js" \
+ "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}/lib.js"
+ install -Dm644 "schemas/org.gnome.shell.extensions.suspend-button.gschema.xml" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.suspend-button.gschema.xml"
+}
diff --git a/gnome-shell-extension-suspend-button.install b/gnome-shell-extension-suspend-button.install
new file mode 100644
index 000000000000..8cd7bfd8ba3b
--- /dev/null
+++ b/gnome-shell-extension-suspend-button.install
@@ -0,0 +1,11 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_upgrade() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}
+
+post_remove() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+}