summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Milde2016-11-08 10:19:40 +0100
committerDaniel Milde2016-11-08 10:19:40 +0100
commitc14f79a6c8452ad3b6d01ba557760e6e7709b712 (patch)
tree0c800793978101cbe9448f80a5169fcc34268757
parent848038d75ad4b5e08868c784800bcefcd676982a (diff)
downloadaur-c14f79a6c8452ad3b6d01ba557760e6e7709b712.tar.gz
new pkgbuild merged
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD42
-rw-r--r--gschemas.install30
3 files changed, 34 insertions, 60 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1424401b9822..70f1a188f0c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
-# Generated by mksrcinfo v8
-# Wed Oct 12 15:41:13 UTC 2016
pkgbase = gnome-shell-extension-system-monitor-git
- pkgdesc = speed up gnome-shell animations
- pkgver = r704.8b31f07
- pkgrel = 1
- url = https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet
- install = gschemas.install
+ pkgdesc = System monitor extension for Gnome-Shell (display mem swap cpu usage)
+ pkgver = 704.8b31f07
+ pkgrel = 2
+ url = http://github.com/paradoxxxzero/gnome-shell-system-monitor-applet
arch = any
license = GPL3
makedepends = git
- depends = gnome-shell
- source = git+https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet
- md5sums = SKIP
+ depends = gnome-shell>=3.10
+ depends = libgtop
+ depends = networkmanager
+ provides = system-monitor-applet gnome-shell-system-monitor-applet-git
+ conflicts = gnome-shell-system-monitor-applet-git
+ replaces = gnome-shell-system-monitor-applet-git
+ source = git://github.com/paradoxxxzero/gnome-shell-system-monitor-applet.git
+ sha1sums = SKIP
pkgname = gnome-shell-extension-system-monitor-git
diff --git a/PKGBUILD b/PKGBUILD
index ae5377687fde..8240ce8f4ad1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,30 @@
-# Maintainer: Michael Schubert <mschu.dev at gmail>
+# Maintainer: Daniel Milde <daniel@milde.cz>
+# Contributor: Florian Mounier aka paradoxxxzero <paradoxxx.zero@gmail.com>
+# Contributor: Michael Schubert <mschu.dev at gmail>
+
pkgname=gnome-shell-extension-system-monitor-git
-_pkgname=gnome-shell-system-monitor-applet
-pkgver=r704.8b31f07
-pkgrel=1
-pkgdesc="speed up gnome-shell animations"
+pkgver=704.8b31f07
+_gitname=gnome-shell-system-monitor-applet
+pkgrel=2
+pkgdesc="System monitor extension for Gnome-Shell (display mem swap cpu usage)"
arch=('any')
-url="https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet"
+url="http://github.com/paradoxxxzero/gnome-shell-system-monitor-applet"
license=('GPL3')
-depends=('gnome-shell')
+depends=('gnome-shell>=3.10' 'libgtop' 'networkmanager')
makedepends=('git')
-install='gschemas.install'
-source=("git+https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet")
-md5sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/$_pkgname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+provides=("system-monitor-applet gnome-shell-system-monitor-applet-git")
+replaces=("gnome-shell-system-monitor-applet-git")
+conflicts=("gnome-shell-system-monitor-applet-git")
+source=('git://github.com/paradoxxxzero/gnome-shell-system-monitor-applet.git')
+sha1sums=('SKIP')
package() {
- cd "$srcdir/$_pkgname"
+ cd "$srcdir/$_gitname"
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/"
+ cp -R "system-monitor@paradoxxx.zero.gmail.com" "$pkgdir/usr/share/gnome-shell/extensions"
+}
- for i in $(find -type f)
- do
- install -Dm 644 $i $pkgdir/usr/share/gnome-shell/extensions/$i
- done
+pkgver() {
+ cd $_gitname
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
diff --git a/gschemas.install b/gschemas.install
deleted file mode 100644
index 7f4546e45017..000000000000
--- a/gschemas.install
+++ /dev/null
@@ -1,30 +0,0 @@
-post_install() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_install
-}
-
-post_upgrade() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
- instructions_upgrade
-}
-
-post_remove() {
- /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
-}
-
-instructions_install() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r).
-Activate the extension with gnome-tweak-tool.
-
-EOF
-}
-
-instructions_upgrade() {
- /bin/cat << EOF
-
-Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
-
-EOF
-}