summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormschubert2016-04-24 13:59:45 +0100
committermschubert2016-04-24 14:00:03 +0100
commitcafd1d63efa7e6d66a0ce939fa31ffadbf0760d4 (patch)
tree84f226952ca440e1136b5924d927c6490f98f108
downloadaur-cafd1d63efa7e6d66a0ce939fa31ffadbf0760d4.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--gschemas.install30
3 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f0b546410b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Apr 24 12:59:38 UTC 2016
+pkgbase = gnome-shell-extension-system-monitor-git
+ pkgdesc = speed up gnome-shell animations
+ pkgver = r704.8b31f07
+ pkgrel = 1
+ url = https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet
+ install = gschemas.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell<3.21
+ source = git+https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-system-monitor-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0fc0804c2fc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Michael Schubert <mschu.dev at gmail>
+pkgname=gnome-shell-extension-system-monitor-git
+_pkgname=gnome-shell-system-monitor-applet
+pkgver=r704.8b31f07
+pkgrel=1
+pkgdesc="speed up gnome-shell animations"
+arch=('any')
+url="https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet"
+license=('GPL3')
+depends=('gnome-shell<3.21')
+makedepends=('git')
+install='gschemas.install'
+source=("git+https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+
+ for i in $(find -type f)
+ do
+ install -Dm 644 $i $pkgdir/usr/share/gnome-shell/extensions/$i
+ done
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..7f4546e45017
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,30 @@
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_install
+}
+
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_upgrade
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+instructions_install() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r).
+Activate the extension with gnome-tweak-tool.
+
+EOF
+}
+
+instructions_upgrade() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
+
+EOF
+}