summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Milde2018-11-15 21:17:43 +0100
committerDaniel Milde2018-11-15 21:18:39 +0100
commitf0b23891208201cc669e9a635951e2c49aeb5705 (patch)
treefedf791ff706c15afd80765a65fbcaaab51d2982
parent90ad01fc09b9b30911f5693aa87e8f0df8d7abd5 (diff)
downloadaur-f0b23891208201cc669e9a635951e2c49aeb5705.tar.gz
install gschema
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD22
-rw-r--r--gschemas.install18
3 files changed, 36 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91932f1f72ef..d1ed12d968a3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
# Generated by mksrcinfo v8
-# Tue May 29 18:22:10 UTC 2018
+# Čt lis 15 20:18:30 UTC 2018
pkgbase = gnome-shell-extension-system-monitor-git
pkgdesc = System monitor extension for Gnome-Shell (display mem swap cpu usage)
- pkgver = 877.751d557
+ pkgver = 884.21ae32a
pkgrel = 1
url = http://github.com/paradoxxxzero/gnome-shell-system-monitor-applet
+ install = gschemas.install
arch = any
license = GPL3
makedepends = git
diff --git a/PKGBUILD b/PKGBUILD
index f83051974002..ba73e851ed02 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
# Maintainer: Daniel Milde <daniel@milde.cz>
+# Contributor: Daniel Pereira <daniel@garajau.com.br>
# Contributor: Florian Mounier aka paradoxxxzero <paradoxxx.zero@gmail.com>
-# Contributor: Michael Schubert <mschu.dev at gmail>
+# Contributor: Michael Schubert <mschu.dev at gmail>
+_reponame=gnome-shell-system-monitor-applet
pkgname=gnome-shell-extension-system-monitor-git
-pkgver=877.751d557
-_gitname=gnome-shell-system-monitor-applet
+pkgver=884.21ae32a
pkgrel=1
pkgdesc="System monitor extension for Gnome-Shell (display mem swap cpu usage)"
arch=('any')
@@ -15,16 +16,23 @@ makedepends=('git')
provides=("system-monitor-applet" "gnome-shell-system-monitor-applet-git")
replaces=("gnome-shell-system-monitor-applet-git")
conflicts=("gnome-shell-system-monitor-applet-git")
+install="gschemas.install"
source=('git+https://github.com/paradoxxxzero/gnome-shell-system-monitor-applet.git')
sha1sums=('SKIP')
package() {
- cd "$srcdir/$_gitname"
- mkdir -p "$pkgdir/usr/share/gnome-shell/extensions/"
- cp -R "system-monitor@paradoxxx.zero.gmail.com" "$pkgdir/usr/share/gnome-shell/extensions"
+ cd "$srcdir/$_reponame"
+
+ # Install the extension
+ install -d "$pkgdir/usr/share/gnome-shell/extensions/"
+ cp -R "system-monitor@paradoxxx.zero.gmail.com" "$pkgdir/usr/share/gnome-shell/extensions"
+
+ # Install the gschema
+ install -d "$pkgdir/usr/share/glib-2.0/schemas"
+ install -m 644 "system-monitor@paradoxxx.zero.gmail.com/schemas/org.gnome.shell.extensions.system-monitor.gschema.xml" "$pkgdir/usr/share/glib-2.0/schemas/"
}
pkgver() {
- cd $_gitname
+ cd $_reponame
echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..1ca4a1686358
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,18 @@
+# Installs the schema to the right folder so we can use the `gsettings`
+# commands to configure this plugin.
+
+post_install() {
+ recompile
+}
+
+post_upgrade() {
+ recompile
+}
+
+post_remove() {
+ recompile
+}
+
+recompile() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}