summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Grossar2020-10-28 10:11:48 +0100
committerLukas Grossar2020-10-28 15:25:18 +0100
commit8584a4848812ed3f3e796e815eef486879bc1da0 (patch)
tree40294c3c6c3a4fb3fff1d2d00b14d0637b174120
downloadaur-8584a4848812ed3f3e796e815eef486879bc1da0.tar.gz
initial build for v16
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b99b5c843515
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = gnome-shell-extension-taskwhisperer
+ pkgdesc = Gnome Shell TaskWarrior integration
+ pkgver = 16
+ pkgrel = 1
+ url = https://github.com/cinatic/taskwhisperer
+ arch = any
+ license = GPL3
+ depends = gnome-shell
+ source = https://github.com/cinatic/taskwhisperer/archive/v16.tar.gz
+ sha256sums = b52a721260267464322f27267b209c93d4cc91e722114273b9161e621504e3ea
+
+pkgname = gnome-shell-extension-taskwhisperer
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87a4f46839e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Lukas Grossar <lukas.grossar@gmail.com>
+
+pkgname=gnome-shell-extension-taskwhisperer
+_pkgname=taskwhisperer
+pkgver=16
+pkgrel=1
+pkgdesc="Gnome Shell TaskWarrior integration"
+arch=('any')
+url="https://github.com/cinatic/taskwhisperer"
+license=('GPL3')
+depends=('gnome-shell')
+source=("https://github.com/cinatic/taskwhisperer/archive/v${pkgver}.tar.gz")
+sha256sums=('b52a721260267464322f27267b209c93d4cc91e722114273b9161e621504e3ea')
+
+package() {
+ _extid='taskwhisperer-extension@infinicode.de'
+ install -dm755 "$pkgdir/usr/share/gnome-shell/extensions"
+ cp -r "${_pkgname}-${pkgver}/${_extid}" "${pkgdir}/usr/share/gnome-shell/extensions"
+}