summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOle Ernst2015-06-26 10:10:34 +0200
committerOle Ernst2015-06-26 10:10:34 +0200
commit58d10059b65a5d6ecc774bd6ce17c5c5ed90939f (patch)
tree108693ab237042f1fb2019f2e21b58b374915cca
downloadaur-58d10059b65a5d6ecc774bd6ce17c5c5ed90939f.tar.gz
migrate to aur4
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
-rw-r--r--gnome-shell-extension-timer-git.install12
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..859d31ccb392
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-timer-git
+ pkgdesc = A simple timer extension for gnome-shell
+ pkgver = 20121103
+ pkgrel = 1
+ url = http://github.com/olebowle/gnome-shell-timer
+ install = gnome-shell-extension-timer-git.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ depends = python2
+ source = git://github.com/olebowle/gnome-shell-timer.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-timer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..102038a57ce4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Ole Ernst <olebowle at gmx dot com>
+pkgname=gnome-shell-extension-timer-git
+pkgver=20121103
+pkgrel=1
+pkgdesc="A simple timer extension for gnome-shell"
+arch=('any')
+url="http://github.com/olebowle/gnome-shell-timer"
+license=('GPL3')
+depends=('gnome-shell' 'python2')
+makedepends=('git')
+install="$pkgname.install"
+source=("git://github.com/olebowle/gnome-shell-timer.git")
+sha256sums=('SKIP')
+
+package() {
+ cd gnome-shell-timer
+ install -Dm755 gnome-shell-timer-config.py "$pkgdir/usr/bin/gnome-shell-timer-config"
+ install -Dm644 gnome-shell-timer-config.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/gnome-shell-timer-config.svg"
+ install -Dm644 utilities-timer-symbolic.svg "$pkgdir/usr/share/icons/hicolor/scalable/apps/utilities-timer-symbolic.svg"
+ install -Dm644 gnome-shell-timer-config.desktop "$pkgdir/usr/share/applications/gnome-shell-timer-config.desktop"
+ install -Dm644 org.gnome.shell.extensions.timer.gschema.xml "$pkgdir/usr/share/glib-2.0/schemas/org.gnome.shell.extensions.timer.gschema.xml"
+
+ mkdir -p "$pkgdir/usr/share/gnome-shell/extensions"
+ cp -r "timer@olebowle.gmx.com" "$pkgdir/usr/share/gnome-shell/extensions/"
+
+ cd po
+ for _lang in */; do
+ mkdir -p "$pkgdir/usr/share/locale/${_lang}LC_MESSAGES"
+ msgfmt -cv -o "$pkgdir/usr/share/locale/${_lang}LC_MESSAGES/gnome-shell-timer.mo" "${_lang}gnome-shell-timer.po"
+ done
+}
diff --git a/gnome-shell-extension-timer-git.install b/gnome-shell-extension-timer-git.install
new file mode 100644
index 000000000000..32e402d08cc2
--- /dev/null
+++ b/gnome-shell-extension-timer-git.install
@@ -0,0 +1,12 @@
+post_install() {
+ glib-compile-schemas usr/share/glib-2.0/schemas
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}