summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtakar Jašek2020-06-25 16:07:07 +0200
committerOtakar Jašek2020-06-25 16:07:07 +0200
commit6324427d2b7e04bf0d01b10dbf71f65a367f69b1 (patch)
treedc2244e15e09dae25fd33ffc14b9b3ffa52e6734
downloadaur-6324427d2b7e04bf0d01b10dbf71f65a367f69b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD45
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..394e42c1b7bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = gnome-shell-extension-todotxt-git
+ pkgdesc = Todo.txt GUI for gnome-shell
+ pkgver = v30.r9.g6ec0377
+ pkgrel = 1
+ url = https://gitlab.com/bartl/todo-txt-gnome-shell-extension
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python
+ makedepends = python-lxml
+ makedepends = python-jsonschema
+ makedepends = python-six
+ makedepends = moreutils
+ makedepends = glib2
+ makedepends = jq
+ depends = gnome-shell
+ provides = gnome-shell-extension-todotxt
+ conflicts = gnome-shell-extension-todotxt
+ source = todo-txt::git+https://gitlab.com/bartl/todo-txt-gnome-shell-extension.git
+ sha512sums = SKIP
+
+pkgname = gnome-shell-extension-todotxt-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4fa65c20c42b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: otaj <jasek.ota at gmail dot com>
+
+pkgname=gnome-shell-extension-todotxt-git
+_pkgname="${pkgname%-*}"
+_pkgdir=todo-txt
+pkgver=v30.r9.g6ec0377
+pkgrel=1
+pkgdesc="Todo.txt GUI for gnome-shell"
+arch=('any')
+url="https://gitlab.com/bartl/todo-txt-gnome-shell-extension"
+license=('GPL')
+depends=('gnome-shell')
+makedepends=('git' 'python' 'python-lxml' 'python-jsonschema' 'python-six' 'moreutils' 'glib2' 'jq')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgdir}::git+${url}.git")
+sha512sums=('SKIP')
+
+prepare() {
+ cd "${_pkgdir}"
+ git submodule update --init --recursive
+}
+
+pkgver() {
+ cd "${_pkgdir}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/${_pkgdir}"
+ python json2schema.py
+ jq '.version="'${pkgver}'"' metadata.json | sponge metadata.json
+ glib-compile-schemas schemas
+}
+
+package() {
+ cd "${_pkgdir}"
+ _extname=$(grep -Po '(?<="uuid": ")[^"]*' metadata.json)
+ _destdir="${pkgdir}/usr/share/gnome-shell/extensions/${_extname}"
+ for f in `cat dist_files.lst` ; do
+ if [ ! -d $f ] ; then
+ install -DTm 644 $f ${_destdir}/$f;
+ fi
+ done
+}