summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Andersson2016-10-31 01:40:32 +0100
committerMaxim Andersson2016-10-31 01:41:46 +0100
commit6458ec3cc6f163405d8ebb04b6552cd5ef969bb7 (patch)
tree8bf670eb5481702e4ee4ce8dca11ce189e3b7ce2
downloadaur-6458ec3cc6f163405d8ebb04b6552cd5ef969bb7.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
-rw-r--r--gnome-shell-extension-topicons-plus.install8
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8afec47a3df9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Oct 31 00:30:48 UTC 2016
+pkgbase = gnome-shell-extension-topicons-plus
+ pkgdesc = Moves legacy tray icons to the top panel
+ pkgver = 17
+ pkgrel = 1
+ url = https://github.com/phocean/TopIcons-plus
+ install = gnome-shell-extension-topicons-plus.install
+ arch = any
+ license = GPL2
+ depends = gnome-shell
+ source = https://github.com/phocean/TopIcons-plus/archive/v17.tar.gz
+ sha256sums = 7603b5c03c9082cae660e2ddc6e14c2321321a5ae536466fb515a78c38aef3d9
+
+pkgname = gnome-shell-extension-topicons-plus
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8a3c23b560a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Maxim Andersson <thesilentboatman@gmail.com>
+
+pkgname=gnome-shell-extension-topicons-plus
+pkgver=17
+pkgrel=1
+pkgdesc="Moves legacy tray icons to the top panel"
+arch=('any')
+url="https://github.com/phocean/TopIcons-plus"
+license=('GPL2')
+depends=('gnome-shell')
+install=${pkgname}.install
+source=("https://github.com/phocean/TopIcons-plus/archive/v${pkgver}.tar.gz")
+sha256sums=('7603b5c03c9082cae660e2ddc6e14c2321321a5ae536466fb515a78c38aef3d9')
+
+package() {
+ _uuid='TopIcons@phocean.net'
+
+ cd "${srcdir}/TopIcons-plus-${pkgver}"
+
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+ install -Dm644 "schemas/org.gnome.shell.extensions.topicons.gschema.xml" \
+ -t "${pkgdir}/usr/share/glib-2.0/schemas/"
+
+ cp -af * "${pkgdir}/usr/share/gnome-shell/extensions/${_uuid}"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension-topicons-plus.install b/gnome-shell-extension-topicons-plus.install
new file mode 100644
index 000000000000..14363a51da8a
--- /dev/null
+++ b/gnome-shell-extension-topicons-plus.install
@@ -0,0 +1,8 @@
+post_install() {
+ echo ''
+ echo '==> To enable TopIcons Plus:'
+ echo '==> Reload Gnome Shell with Alt-F2 r'
+ echo '==> Enable it with the gnome-tweak-tool'
+ echo '==> or run "gnome-shell-extension-tool -e TopIcons@phocean.net"'
+ echo ''
+}