summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorj.r2021-04-13 09:42:54 +0200
committerj.r2021-04-13 09:42:54 +0200
commitf01d67b831cec666ea2302b907f5e44a9dda4957 (patch)
tree195db4ecad2d829fbf181e0c8e0355a96c640294
parent46b637272efdb75d9e001682dbeb210f889f40af (diff)
downloadaur-f01d67b831cec666ea2302b907f5e44a9dda4957.tar.gz
gnome-shell-extension-topicons-plus: GNOME 40 patch
-rw-r--r--.SRCINFO4
-rw-r--r--0001-fix-compatibility-with-gnome40.patch54
-rw-r--r--PKGBUILD14
3 files changed, 68 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 64daecd1de83..d3cf61d08a47 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = gnome-shell-extension-topicons-plus
pkgdesc = Moves legacy tray icons to the top panel
pkgver = 27
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/phocean/TopIcons-plus
arch = any
license = GPL2
depends = gnome-shell
source = gnome-shell-extension-topicons-plus-27.tar.gz::https://github.com/phocean/TopIcons-plus/archive/27.tar.gz
+ source = 0001-fix-compatibility-with-gnome40.patch
sha256sums = 51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8
+ sha256sums = e4cb4ec7b74d6e1d4f5323e3d607dc56aca984fbde87590bc4e44c216c8504f8
pkgname = gnome-shell-extension-topicons-plus
diff --git a/0001-fix-compatibility-with-gnome40.patch b/0001-fix-compatibility-with-gnome40.patch
new file mode 100644
index 000000000000..2b9a6c443e7d
--- /dev/null
+++ b/0001-fix-compatibility-with-gnome40.patch
@@ -0,0 +1,54 @@
+From 98cd17aa324a031e2ee3d344582dfdafd1e4642f Mon Sep 17 00:00:00 2001
+From: Tiramisu Mokka <kofemann@gmail.com>
+Date: Fri, 19 Mar 2021 19:00:32 +0100
+Subject: [PATCH] fix compatibility with gnome40
+
+---
+ metadata.json | 5 ++---
+ prefs.js | 6 ++----
+ 2 files changed, 4 insertions(+), 7 deletions(-)
+
+diff --git a/metadata.json b/metadata.json
+index e4c9691..8a07918 100644
+--- a/metadata.json
++++ b/metadata.json
+@@ -3,11 +3,10 @@
+ "name": "TopIcons Plus",
+ "gettext-domain": "TopIcons-Plus",
+ "shell-version": [
+- "3.34",
+- "3.36"
++ "40"
+ ],
+ "settings-schema": "org.gnome.shell.extensions.topicons",
+ "url": "https://github.com/phocean/TopIcons-plus",
+ "uuid": "TopIcons@phocean.net",
+- "version": 27
++ "version": 28
+ }
+diff --git a/prefs.js b/prefs.js
+index bd372d2..f6b1277 100644
+--- a/prefs.js
++++ b/prefs.js
+@@ -12,7 +12,7 @@ const Gettext = imports.gettext.domain(Me.metadata['gettext-domain']);
+ const _ = Gettext.gettext;
+
+ function init() {
+- Convenience.initTranslations();
++ ExtensionUtils.initTranslations();
+ }
+
+ const TopIconsPlusSettings = new GObject.Class({
+@@ -180,8 +180,6 @@ const TopIconsPlusSettings = new GObject.Class({
+ });
+
+ function buildPrefsWidget() {
+- let widget = new TopIconsPlusSettings();
+- widget.show_all();
++ return new TopIconsPlusSettings();
+
+- return widget;
+ }
+--
+2.31.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 16596cb3e769..f504195d9a01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,22 @@
pkgname=gnome-shell-extension-topicons-plus
pkgver=27
-pkgrel=2
+pkgrel=3
pkgdesc="Moves legacy tray icons to the top panel"
arch=('any')
url="https://github.com/phocean/TopIcons-plus"
license=('GPL2')
depends=('gnome-shell')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phocean/TopIcons-plus/archive/${pkgver}.tar.gz")
-sha256sums=('51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/phocean/TopIcons-plus/archive/${pkgver}.tar.gz"
+ "0001-fix-compatibility-with-gnome40.patch")
+sha256sums=('51c94aa52dd19e9f3740fee9580e47961414d7aec63dd588cb9c067cef8f4ad8'
+ 'e4cb4ec7b74d6e1d4f5323e3d607dc56aca984fbde87590bc4e44c216c8504f8')
+
+prepare() {
+ cd "${srcdir}/TopIcons-plus-${pkgver}"
+
+ patch -p1 -i ${srcdir}/0001-fix-compatibility-with-gnome40.patch
+}
build(){
cd "${srcdir}/TopIcons-plus-${pkgver}"