summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxim Andersson2015-06-08 16:07:50 +0200
committerMaxim Andersson2015-06-08 16:07:50 +0200
commit8598b7a25b3d86086e2ad5d00752b6e2a814b121 (patch)
tree30f2ec498038e860adce8cb951efe5f3ce2cab22
downloadaur-8598b7a25b3d86086e2ad5d00752b6e2a814b121.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
-rw-r--r--gnome-shell-extension-transmission-daemon-git.install19
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3f95aa240019
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-transmission-daemon-git
+ pkgdesc = Gnome Shell indicator for transmission-daemon
+ pkgver = r104.fe6fe88
+ pkgrel = 1
+ url = https://github.com/eonpatapon/gnome-shell-extension-transmission-daemon
+ install = gnome-shell-extension-transmission-daemon-git.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell
+ conflicts = gnome-shell-extension-transmission-daemon
+ source = git://github.com/eonpatapon/gnome-shell-extension-transmission-daemon.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-transmission-daemon-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9dfe2184652
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Maxim Andersson <thesilentboatman@gmail.com>
+
+pkgname=gnome-shell-extension-transmission-daemon-git
+_gitname=gnome-shell-extension-transmission-daemon
+pkgver=r104.fe6fe88
+pkgrel=1
+pkgdesc="Gnome Shell indicator for transmission-daemon"
+arch=('any')
+url="https://github.com/eonpatapon/gnome-shell-extension-transmission-daemon"
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('git')
+conflicts=('gnome-shell-extension-transmission-daemon')
+install=${pkgname}.install
+source=('git://github.com/eonpatapon/gnome-shell-extension-transmission-daemon.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ _uuid='transmission-daemon@patapon.info'
+
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions"
+ install -d "${pkgdir}/usr/share/glib-2.0/schemas/"
+
+ cd "${srcdir}/${_gitname}"
+ mv "${_uuid}/schemas/org.gnome.shell.extensions.mediaplayer.gschema.xml" \
+ "${pkgdir}/usr/share/glib-2.0/schemas/"
+ cp -af "${_uuid}" "${pkgdir}/usr/share/gnome-shell/extensions/"
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/gnome-shell-extension-transmission-daemon-git.install b/gnome-shell-extension-transmission-daemon-git.install
new file mode 100644
index 000000000000..9ebaeab2a04d
--- /dev/null
+++ b/gnome-shell-extension-transmission-daemon-git.install
@@ -0,0 +1,19 @@
+post_install() {
+ post_upgrade
+
+ echo ''
+ echo '==> To enable:'
+ echo '==> Reload Gnome Shell with Alt-F2 r'
+ echo '==> Enable it with the gnome-tweak-tool'
+ echo '==> or run "gnome-shell-extension-tool -e transmission-daemon@patapon.info"'
+ echo ''
+}
+
+post_upgrade() {
+ glib-compile-schemas /usr/share/glib-2.0/schemas
+}
+
+post_remove() {
+ post_upgrade
+}
+