summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal Donat2016-11-20 19:13:17 +0100
committerMichal Donat2016-11-20 19:13:17 +0100
commitc8904bdd2cbdfbde869e200619676b3e7a4b76ec (patch)
treed7704d6004c1e7ce4c53e0def8869cbe490b42fa
downloadaur-c8904bdd2cbdfbde869e200619676b3e7a4b76ec.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
-rw-r--r--gschemas.install30
3 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb804edd5b56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = gnome-shell-extension-transparent-osd-git
+ pkgdesc = Gnome shell extension to add transparency to the OSD
+ pkgver = r4.45f2400
+ pkgrel = 1
+ url = https://github.com/ipaq3870/gsext-transparent-osd
+ install = gschemas.install
+ arch = any
+ license = GPL2
+ makedepends = git
+ depends = gnome-shell
+ source = git+https://github.com/ipaq3870/gsext-transparent-osd
+ md5sums = SKIP
+
+pkgname = gnome-shell-extension-transparent-osd-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22fafee55f88
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Michal DonĂ¡t <michal at donat dot cz>
+pkgname=gnome-shell-extension-transparent-osd-git
+_pkgname=gsext-transparent-osd
+pkgver=r4.45f2400
+pkgrel=1
+pkgdesc="Gnome shell extension to add transparency to the OSD"
+arch=('any')
+url="https://github.com/ipaq3870/gsext-transparent-osd"
+license=('GPL2')
+depends=('gnome-shell')
+makedepends=('git')
+install='gschemas.install'
+source=("git+https://github.com/ipaq3870/gsext-transparent-osd")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}/transparentosd@ipaq3870"
+
+ for i in $(find -type f); do
+ install -Dm 644 "$i" "${pkgdir}/usr/share/gnome-shell/extensions/transparentosd@ipaq3870/${i}"
+ done
+}
diff --git a/gschemas.install b/gschemas.install
new file mode 100644
index 000000000000..7f4546e45017
--- /dev/null
+++ b/gschemas.install
@@ -0,0 +1,30 @@
+post_install() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_install
+}
+
+post_upgrade() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+ instructions_upgrade
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas/
+}
+
+instructions_install() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r).
+Activate the extension with gnome-tweak-tool.
+
+EOF
+}
+
+instructions_upgrade() {
+ /bin/cat << EOF
+
+Restart GNOME Shell ([Alt]+[F2], r) to load the upgraded extension.
+
+EOF
+}