summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilip Goto2020-04-13 21:25:05 +0200
committerPhilip Goto2020-04-13 21:25:05 +0200
commitf2ff0002c971177c2cdc5df819a46a711169b91e (patch)
treeec90666ad6505e0393cce9cec30a88fe1f431c8f
downloadaur-f2ff0002c971177c2cdc5df819a46a711169b91e.tar.gz
Initialize package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f8c0ee1b5d23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = gnome-shell-extension-transparent-top-bar-git
+ pkgdesc = Bring back the transparent top bar when free-floating in GNOME Shell 3.32
+ pkgver = r10.31714cf
+ pkgrel = 1
+ url = https://extensions.gnome.org/extension/1708/transparent-top-bar/
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = gnome-shell
+ provides = gnome-shell-extension-transparent-top-bar
+ conflicts = gnome-shell-extension-transparent-top-bar
+ source = git+https://github.com/zhanghai/gnome-shell-extension-transparent-top-bar.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-transparent-top-bar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0014ed62b12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+
+pkgname=gnome-shell-extension-transparent-top-bar-git
+pkgver=r10.31714cf
+pkgrel=1
+pkgdesc="Bring back the transparent top bar when free-floating in GNOME Shell 3.32"
+arch=(any)
+url="https://extensions.gnome.org/extension/1708/transparent-top-bar/"
+license=(GPL)
+depends=(gnome-shell)
+makedepends=(git)
+provides=(gnome-shell-extension-transparent-top-bar)
+conflicts=(gnome-shell-extension-transparent-top-bar)
+source=("git+https://github.com/zhanghai/gnome-shell-extension-transparent-top-bar.git")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd gnome-shell-extension-transparent-top-bar
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd gnome-shell-extension-transparent-top-bar
+ install -d "${pkgdir}/usr/share/gnome-shell/extensions/transparent-top-bar@zhanghai.me"
+ install -t "${pkgdir}/usr/share/gnome-shell/extensions/transparent-top-bar@zhanghai.me" src/*
+}