summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTony Lambiris2018-09-21 18:48:40 -0400
committerTony Lambiris2018-09-21 18:48:40 -0400
commit8455359a6c395e69471d0448064b7b63ef3f88a3 (patch)
tree4780c790e78770b1159468e69628bd39c8a1785d
downloadaur-8455359a6c395e69471d0448064b7b63ef3f88a3.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7cbd8c6fc78e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = gnome-shell-extension-transparent-window-moving-git
+ pkgdesc = Makes the window semi-transparent when moving or resizing.
+ pkgver = 18.1891bce
+ pkgrel = 1
+ url = https://github.com/Noobsai/transparent-window-moving
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = gnome-shell
+ source = gnome-shell-extension-transparent-window-moving-git::git+https://github.com/Noobsai/transparent-window-moving.git
+ sha256sums = SKIP
+
+pkgname = gnome-shell-extension-transparent-window-moving-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4c6c1fb61d0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Tony Lambiris <tony@criticalstack.com>
+
+pkgname=gnome-shell-extension-transparent-window-moving-git
+pkgver=18.1891bce
+pkgrel=1
+pkgdesc="Makes the window semi-transparent when moving or resizing."
+arch=('any')
+url="https://github.com/Noobsai/transparent-window-moving"
+license=('GPL3')
+depends=('gnome-shell')
+makedepends=('git')
+source=("${pkgname}::git+https://github.com/Noobsai/transparent-window-moving.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname}
+
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+package() {
+ cd ${pkgname}
+
+ make EXTENSIONDIR="${pkgdir}/usr/share/gnome-shell/extensions/" install
+}